problems to connect to mysql with base [closed]

asked 2014-06-14 08:25:26 +0200

Johnny13 gravatar image

updated 2015-09-04 21:05:27 +0200

Alex Kemp gravatar image

Hello, I have problems to connect to my mysql database with dbase. I upgraded from OpenSuse 12.3 to 13.1. Everything worked fine in OpenSuse 12.3. Now I use libreoffice 4.1.5.3. I can connect to my database with other programs like the mysql client or the Perl DBD module. To connect to the mysqld server I use a socket. The database wizard of base seems fine with using a socket. After I set everything up in the wizard, I klicked the test button in the wizard and base says that a connection could be made. Once I am out of the wizard I get the error "Can't connect to MySql server on 127.0.0.1 (111)". Why does it say that? I told it to use a socket (which worked in opensuse 12.3 and with that version of libreoffice). In the configuration of the mysqld server I use the lines skip_networking socket=/home/path/to/mysql.socket

When I don't use "skip_networking" everything works fine with base. I can connect to the mysqld server with base. But I don't want to use networking since I think it is a security risk. And I only use the database locally on my machine. This could be a bug, or am I missing something? Thanks for your help.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2016-02-25 10:32:00.815811

Comments

The latest versions of mysql server in Linux distribs tend to have a my.cnf that is set up so that network connections are not enabled by default, and the user has to manually change them, the default being socket connection, and an indication of the path to the socket. I have no idea whether something has been changed in the LO code at this level, the socket path might be hardcoded into the program.

Alex Thurgood gravatar imageAlex Thurgood ( 2014-07-18 12:58:34 +0200 )edit