Ask Your Question
0

How can I get spell check to work for French content (in an English install / locale)? [closed]

asked 2014-07-16 01:34:09 +0200

xcheshirecat gravatar image

updated 2014-07-17 13:56:53 +0200

oweng gravatar image

Everything is underline in red. No french words isn't giving a mistake

I have this : http://extensions.libreoffice.org/ext...

I don't know what to do or check

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 23:39:51.619331

Comments

Which operating system and LO version are you using? Is the LO version provided via PPA?

oweng gravatar imageoweng ( 2014-07-17 12:23:09 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2014-07-18 18:42:34 +0200

ajlittoz gravatar image

Sorry if this seems basic to you, no offence intended.

Did you forget to give a specific style to your French paragraphs? When you define a paragraph style, you can choose the base language in the font tab.

Similarly, if you need to "quote" (cite) only a few words within an English paragraph, you can define a character style with a specific language attribute in the font tab. For example, when I want to intentionally "escape" spell checking for procedure or variable names in technical papers, I use a "NoLang" style with language set to "None" (and font set to a monospace family to emphasize the non-literary context of the word).

edit flag offensive delete link more
0

answered 2014-07-16 02:47:26 +0200

oweng gravatar image

The answer here provides a clear check-list of what is required under Tools > Options... > Language Settings > Writing Aids.

edit flag offensive delete link more
0

answered 2014-07-17 02:03:18 +0200

xcheshirecat gravatar image

I did that. it thinks it's in french, but it's like if the dictionary is empty

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-07-16 01:34:09 +0200

Seen: 198 times

Last updated: Jul 18 '14