Ask Your Question
1

Retina Display broken in 4.3 [closed]

asked 2014-07-30 18:37:12 +0200

iandol gravatar image

updated 2016-03-01 16:46:37 +0200

Alex Kemp gravatar image

I'm a new user but do remember trying an earlier version of LO and not having any display problems with my Retina Macbook Pro. But with 4.3 the display is clearly not 2x retina aware, is there some way for me to fix LO to work again with OS X HiDPI displays?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-01 16:47:52.118041

Comments

I do see an open bug on this but without any response: https://bugs.freedesktop.org/show_bug...

iandol gravatar imageiandol ( 2014-07-30 18:42:08 +0200 )edit

fdo#81915 · Status: NEEDINFO

Feel free to add a comment on Bugzilla...

manj_k gravatar imagemanj_k ( 2014-07-30 23:26:52 +0200 )edit
manj_k gravatar imagemanj_k ( 2014-07-31 11:03:51 +0200 )edit

The solution works, but I just downloaded the latest version and encountered the same problem. Is anyone going to fix this?

marivaux gravatar imagemarivaux ( 2015-01-02 22:15:45 +0200 )edit

The resolution has been working fine for me in LibreOffice 4.3.4.1, in OSX Yosemite, but text is fuzzy again in version 4.3.5.2. If I inspect the application with "Get info", I see that the "Open in low resolution" box is checked and greyed out.

ms-studio gravatar imagems-studio ( 2015-02-25 20:07:41 +0200 )edit

Oops, actually the versions I was running were already out of date. Retina resolution is working fine, both in current "Still" (4.3.6.2) and "Fresh" (4.4.0.3) releases.

ms-studio gravatar imagems-studio ( 2015-02-25 20:31:41 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-08-01 16:18:02 +0200

iandol gravatar image

updated 2014-08-02 15:05:34 +0200

From bug fdo#80939:

It looks like the LibreOffice.app/Contents/Info.plist shows a "false" value for NSHighResolutionCapable causing it to not use retina text rendering.

You need to change this:

<key>NSHighResolutionCapable</key>
<false/>

To this:

<key>NSHighResolutionCapable</key>
<true/>

Note: if you want to fix an existing copy of LibreOffice, you need to update the Info.plist, then rename LibreOffice.app to something else like LibreOffice2.app, open the application and see that retina works, then close and rename it back to LibreOffice.app. I'm not sure how else to clear the cached value but that works.

edit flag offensive delete link more

Comments

You can clear the cached value in the database in OS X Launch Services as follows:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -v -f /where/is/LibreOffice.app
Takeshi Abe gravatar imageTakeshi Abe ( 2014-11-07 08:02:00 +0200 )edit

This solution is not working for me. I am using OS X 10.10 (Yosemite).

safdariqbal gravatar imagesafdariqbal ( 2015-01-15 06:10:34 +0200 )edit

this step half worked in 10.10, however the above console command had no effect, the changes only applied when renaming the app..

Edit: after renaming it back to LibreOffice, and running the command again with sudo, the changes took effect. not sure if this is a glitch or some cache issue but eventually the retina display settings stuck with the original file name, hope this helps someone..

ronlaws86 gravatar imageronlaws86 ( 2015-06-18 10:33:41 +0200 )edit

I'm on 10.11.6 (15G31) and use LO 5.2.4.

<key>NSHighResolutionCapable</key>

is already set to true, to no effect. "Open in Low Resolution" is unchecked in Finder Info. I'd say re-open this issue.

alaistair__b gravatar imagealaistair__b ( 2016-08-26 13:54:53 +0200 )edit
0

answered 2014-07-30 21:43:19 +0200

I have the same issue, it worked before in 4.2.

I am using OS X 10.9 (Mavericks).

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2014-07-30 18:37:12 +0200

Seen: 5,752 times

Last updated: Aug 02 '14