Ask Your Question
0

Base keeps crashing while making forms [closed]

asked 2014-08-03 18:31:07 +0200

PChitnis gravatar image

updated 2016-03-03 19:08:33 +0200

Alex Kemp gravatar image

I am using Libre Office 4.2.5.2 with Windows 7 Ultimate 32 bit OS. I am developing a database with back end as MySQL community edition on localhost and Libre Base as front end for a standalone use, at the first instance. The Base Handbook has been of immense help. But I am running into a peculiar problem. While fine tuning a form with table control, the moment I click on to another column Base crashes! The occurrence is random but once it starts the frequency increases rapidly! The changes saved in the form are lost during recovery. I don't think the problem is with the MYSQL as only test data is stored at this stage i;e; the files are very small. 3 GB is plenty of memory so that can't be a issue. What can the problem be?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 19:08:57.745666

Comments

Could this be a bug? I am trying to develop a small database front end. The crashing of base when moving from one column to another in table control is occurring time and again, in four separate forms at present! I am stuck as I need to use the scope provided by table control especially for appending data/records.

PChitnis gravatar imagePChitnis ( 2014-08-13 06:23:30 +0200 )edit

Are you also making simultaneous changes to data/structure, esp. directly to MySQL by an alternative connection? Had some weird problems that seem to stem from Base not picking up on changes to database structure made directly to MySQL, until Base restart.

doug gravatar imagedoug ( 2014-08-15 16:22:26 +0200 )edit

That does not seem to be a problem. It appears to be connected with the table control and form interaction. I have to go to the extent of saving and closing the form and the Base itself after each table column is adjusted/changed before taking up the next column! You will agree it is pretty tedious process signing in each time. Otherwise the changes made are lost and have to be done all over again. The exact point of crash is after a column is changed and one clicks upon the next column to take it up for adjusting the different properties.

PChitnis gravatar imagePChitnis ( 2014-08-16 18:26:56 +0200 )edit

I am experiencing exactly the same symptoms, only on the Mac platform. Database is stable, MySQL, connecting via localhost. When I click on a column in the related subform table control, Libre Office crashes. Here are some details from the crash log: Process: soffice [3777] Path: /Applications/LibreOffice.app/Contents/MacOS/soffice Identifier: org.libreoffice.script Version: 4.2.6003 (???) Code Type: X86 (Native)

DierkH gravatar imageDierkH ( 2014-09-08 19:30:32 +0200 )edit

Ran out of space. More details: Date/Time: 2014-09-08 11:22:07.640 -0600 OS Version: Mac OS X 10.9.4 (13E28) Report Version: 11 Anonymous UUID: CCE232AC-C298-6DD2-1A22-CDE8B58BCDF0

Sleep/Wake UUID: E086D4A5-208F-4F9F-9C39-2A044BA69B32

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf7fffec

DierkH gravatar imageDierkH ( 2014-09-08 19:34:47 +0200 )edit

I filed a bug report [fdo#82774]. Robert was looking into it but no success. DierkH is requested to add the info to the report. That might get some additional attention. PChitnis

PChitnis gravatar imagePChitnis ( 2014-09-09 12:20:42 +0200 )edit

Copied the MySQL database to OpenSuse 13.1 and also copied the .odb file containing forms to the system. Tried working with the form. Same result! There certainly is a bug linked with the table control. PChitnis

PChitnis gravatar imagePChitnis ( 2014-09-13 18:45:27 +0200 )edit

I have added an attachment to the bug report, hopefully the details within it will help with troubleshooting.

DierkH gravatar imageDierkH ( 2014-09-15 21:02:29 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-09-17 10:03:53 +0200

PChitnis gravatar image

Robert (through bugzilla) working on the bug has linked the problem with height of tablecontrol. It seems the bug is legacy continuing from ooo. Keeping the height to more than 2 rows to be shown avoids the bug! My problem is solved but I do feel something needs to be done at programming level besides recording the matter in the documentation!

Thanks Robert.

Prakash Chitnis

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2014-08-03 18:31:07 +0200

Seen: 1,004 times

Last updated: Sep 17 '14