Ask Your Question
0

Missing line on LibreOffice chart [closed]

asked 2014-09-17 15:40:10 +0100

inept gravatar image

updated 2016-03-03 19:00:47 +0100

Alex Kemp gravatar image

I'm using LibreOffice Calc Version: 4.2.4.2 on Ubuntu 14.04.1

I'm seeing unexpected behavior from the application but I'm not sure if I'm doing things right, so I'm not sure whether it's a bug.

Action taken:

Open Libreoffice Calc

Paste data into spreadsheet, creating a simple two column, 16 line table with labels on top

(image 1)

Move mouse to the top of the screen to get file,edit... help menu select insert-->object-->chart select line chart select "lines only" style

Click "Finish". A new chart is created

(image 2)

Right click chart. Click "data ranges" from the menu.

(image 3)

Click "Add". A new series is created. Click "Select data range" button beside text entry box under "Range for Name" Select a label as the series name from the table by clicking. The data series is named. Click "Y values" under "data ranges" list of dataset attributes.

(image 4)

Click "Select data range" button beside text entry box under "Range for Y values" Select a range of data from the table by dragging. The data series is filled.

click "ok"

Expected behavior: A chart is drawn with a line that uses the selected data.

Actual behavior: A chart is created with no line.

Images named 1-5 can be found at

http://imgur.com/a/zn1R6

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 19:01:19.138743

Comments

You need to fill the range for "Category" too. I miss that in your pictures and in your description.

Regina gravatar imageRegina ( 2014-09-17 16:47:15 +0100 )edit

Okay, I just did that but the line is still missing.

inept gravatar imageinept ( 2014-09-17 17:22:05 +0100 )edit

Recommend updating to 4.3.1.2 by adding deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main to your repos, can be done by sudo apt-add-repository 'deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main';sudo aptitude update;sudo aptitude full-upgrade if you have aptitude [recommended] or sudo apt-add-repository 'deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main';sudo apt-get update;sudo apt-get upgrade.

rautamiekka gravatar imagerautamiekka ( 2014-09-17 18:25:57 +0100 )edit

Did that, closed and reopened the program. Line is still missing.

inept gravatar imageinept ( 2014-09-17 20:43:55 +0100 )edit

Please provide the document itself, so that I can try how it looks here.

Regina gravatar imageRegina ( 2014-09-18 01:16:15 +0100 )edit
inept gravatar imageinept ( 2014-09-18 07:28:11 +0100 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2014-09-18 15:03:19 +0100

Regina gravatar image

Your currency numbers in column C are not really numbers but text. When you switch on the diagnostic tool View > Value Highlighting (Ctrl+F8) you can see, that the column C is in black, indicating text, and the column B is blue, indicating numbers.

To repair the entries do this: Cut the content, clear formatting, insert as "unformatted text". You get the text import dialog. In that dialog set language to English(USA) and click on the header in the preview and set the type of the column to US-English. After inserting click the currency icon in the toolbar to format it as currency.

edit flag offensive delete link more

Comments

This fixed it. You rock!

inept gravatar imageinept ( 2014-09-20 07:16:01 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-17 15:40:10 +0100

Seen: 1,215 times

Last updated: Sep 18 '14