Ask Your Question
0

Spell Checker not working for English (USA) text [closed]

asked 2014-09-18 04:24:45 +0100

mattgloege108 gravatar image

updated 2016-03-03 22:58:39 +0100

Alex Kemp gravatar image

V4.3, default English (USA) Writer Windows 7. Default English (USA) dictionary installed. No matter what I do I simply can't get the blamed spell checker to function normally. I can put an intentionally misspelled word into a document, click on the spell check icons (experimented with both) and it fails to underline in red. When the window opens its says the spell check is complete and offers no alternative spellings. I've been into every nook and cranny in the help menus and can't find a fix. This must be a bad configuration of mine because it has persisted through a number of upgrades. HELP!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 22:58:56.832022

Comments

"English" is not a dictionary. Please edit the question to indicate the variant of English installed (dictionary) and the language the text in the document is set in (shown in the Status Bar). Thanks.

oweng gravatar imageoweng ( 2014-09-18 05:53:26 +0100 )edit

Place the cursor somewhere in the text. What does Tools > Language > For selection indicate? Also, what is your locale and does Tools > Options > Language Settings > Languages > Default language for documents section > Western show "English (USA)" with a leading ABC+tick in blue icon?

oweng gravatar imageoweng ( 2014-09-20 12:32:36 +0100 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2014-09-22 21:43:45 +0100

mattgloege108 gravatar image

Oweng:

"Tools > Language > For selection" indicates "English (USA)". I also looked at "Tools > Language > For paragraph" and "Tools > Language > For Text" and they were unchecked. I checked them both an went back and tried the spell checker and it worked. Subsequently, went back and looked at them again and they had been automatically unchecked. Went back to the the writer and the spell checker still works OK. I went to Tools > Options > Language Settings > Languages > Default language for documents section > Western and it indicates "English (USA)" with a leading ABC+tick in blue icon, which apparently was right all along. Thanks for hour help - hope the fix stays put but I still don't understand why what I did made it all work and then both fields go ahead, reset themselves to UNCHECKED (which put the configuration back to what it was when I had the problem) and the checker still works. Hmmmmm (??)

edit flag offensive delete link more

Comments

It sounds like there was a mixed language setting in the text somewhere that was confusing Writer. The "For all Text" option was probably what fixed the issue. Glad to hear it is now working as expected. In future, in situations where the entire text of a document is set in a single language:

  1. Tools > Language > For all Text > Reset to Default Language (this will set all text to that specified under Default language for documents, which I mentioned above).
oweng gravatar imageoweng ( 2014-09-23 03:01:53 +0100 )edit

Thank youII

mattgloege108 gravatar imagemattgloege108 ( 2014-09-23 04:36:45 +0100 )edit

Thank You!!!

mattgloege108 gravatar imagemattgloege108 ( 2014-09-23 04:38:06 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-18 04:24:45 +0100

Seen: 343 times

Last updated: Sep 23 '14