Ask Your Question
0

How can I get Libreoffice to respect the chosen language with respect to autocorrection?

asked 2014-10-01 14:47:34 +0100

smeyer gravatar image

I have version: 4.2.6.3 on Linux. I use English UK as the User Interface Language. I have Danish as the default for documents. I have marked all text and chosen Danish as the language. When I look at the properties of the text, it is marked as being danish in the language field.

When I type a small i it will be autocorrected to capital I. It uses the english autocorrect list even though document language settings are danish. If I delete that entry in the english autocorrect list it will not do it anymore, but I also write english documents...

In Tools - Langauge, danish is marked for 'selection' but not for 'paragraph' or 'All text' no matter how many times I mark it.

How can I get Libreoffice to respect the chosen language with respect to autocorrection?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-10-01 16:47:16 +0100

Regina gravatar image

I use English UK as the User Interface Language.
Make sure you set it explicit and not as "Default English (UK)".

I have Danish as the default for documents.
Try to mark "Ignore system input language" on the same dialog page.

I have marked all text and chosen Danish as the language
You should not use hard formatting, but set the default language in the paragraph style "Default" and for each other language define a paragraph style, e.g. "text body EN-UK", where you set the language in the "Font" dialog page. Assign the paragraph style before you start to write that paragraph. Do the same for character style for single words in another language.

Or if you insist on hard formating, switch the language using the status bar. Again, first select the language, then start writing.

For to auto correct already existing text, go to Format > AutoCorrect > Apply.

That are only some suggestions. For me different languages work, so it is difficult to guess the reason for your problems.

edit flag offensive delete link more
0

answered 2015-02-25 17:46:54 +0100

Hsonesson gravatar image

updated 2015-02-26 12:13:33 +0100

This is due to a bug in LibreOffice. A similar question is also asked here.

A workaround that works for me is to set the locale language to another language than English in Tools->Options->Language Settings->Languages and then under 'Locale setting'.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-10-01 14:47:34 +0100

Seen: 290 times

Last updated: Feb 26 '15