Ask Your Question
1

LibreOffice fails to start after update -- UNO Exception: InvalidRegistryException: ... duplicate ... [closed]

asked 2012-07-25 11:24:14 +0200

updated 2012-07-25 11:27:34 +0200

LibreOffice fails to start after updating. For debugging, starting LibreOffice from the terminal shows:

UNO Exception: InvalidRegistryException: file:///usr/lib/libreoffice/program/../share/extensions/presenter-screen/components.rdb: duplicate <implementation name="com.sun.star.comp.Draw.framework.PresenterScreenJob">
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'

What can be done about this?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 16:13:19.061236

5 Answers

Sort by » oldest newest most voted
3

answered 2012-07-26 16:06:52 +0200

sberg gravatar image

See https://bugs.freedesktop.org/show_bug.cgi?id=51252 "LO cannot start (reports runtime error with Visual C++ Runtime Library)." Once the fix for that issue is available, it should suffice to just remove ~/.config/libreoffice/3/user/extensions, see point 10 of https://bugs.freedesktop.org/show_bug.cgi?id=51252#c35. (However, it is still a little unclear to me how this issue can hit on Linux, see point 3 of https://bugs.freedesktop.org/show_bug.cgi?id=51252#c35.)

edit flag offensive delete link more
1

answered 2012-07-25 11:27:03 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

You likely have an extension installed for the user locally, while same extension was installed in the system in the meantime. The pragmatic way to solve this is to remove the LibreOffice profile folders at ~/.libreoffice and ~/.config/libreoffice. Alternatively, remove the offending extension before upgrading.

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1028015

edit flag offensive delete link more

Comments

bjoern-michaelsen gravatar imagebjoern-michaelsen ( 2012-07-25 12:01:16 +0200 )edit

hello, please tell me what should I do, i tried this "rm -rf ~/.configure/libreoffice " but nothing has resolved.

Still I am just gettign splashscree of Libreoffice not able to open my build libreoffice

please Reply

Regards, Afreen Bano

afreen bano gravatar imageafreen bano ( 2013-12-18 11:49:29 +0200 )edit
0

answered 2012-08-09 08:10:03 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

this also happens with LO Version 3.6.0.4 (Build ID: 932b512) Ubuntu 11.04. After deleting config/libreoffice/3/user/extensions all was fine

edit flag offensive delete link more
0

answered 2012-08-09 09:39:07 +0200

This also happened with LO Version 3.6.0.4 (Build ID: 932b512) on W7-32 SP1. As with the others, deleting config/libreoffice/3/user/extensions and after launching LO twice, it worked properly. I did try uninstall/install first, but the same fault appeared.

edit flag offensive delete link more

Comments

hello, please tell me what should I do, i tried this "rm -rf ~/.configure/libreoffice " but nothing has resolved.

Still I am just gettign splashscree of Libreoffice not able to open my build libreoffice

please Reply

Regards, Afreen Bano

afreen bano gravatar imageafreen bano ( 2013-12-18 16:54:13 +0200 )edit
0

answered 2012-08-09 08:08:50 +0200

this happens also with LO Version 3.6.0.4 (Build ID: 932b512) on Ubuntu 11.04

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-25 11:24:14 +0200

Seen: 4,479 times

Last updated: Aug 09 '12