Ask Your Question
0

LO 3.5 not recognizing java [closed]

asked 2012-02-23 22:59:45 +0100

peterR gravatar image

updated 2016-03-01 21:58:15 +0100

Alex Kemp gravatar image

I have got LO 3.4 installed on 64bit Kubuntu 11.10 and when I installed LO3.5 I got a series of errors during the install javaldx: Could not find a Java Runtime Environment! (this was after each dictionary from the install archive) On running LO3.5 Tools>Options>java shows no java. adding the same path as on my 3.4 install fails with "the folder you selected does not contain a java runtime environment". I entered /usr/lib/jvm/java-6-openjdk/jre which LO3.4 thinks does contain my jre. (also tried java-1.6.0-openjdk/jre and default-java/jre) I then tried installing openjdk 7 but that did not work either. I have tried reinstalling 3.5 and removing 3.5 (inc config) and 3.4 and reinstalling both - 3.5 first (no java) then 3.4 works fine. At a loss of what to try next.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-15 04:58:35.663053

Comments

since found 2 other questions here, one with OSX and one with CentOS where jre is not being recognised by LO3.5

peterR gravatar imagepeterR ( 2012-02-25 21:27:26 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2012-02-27 22:48:25 +0100

peterR gravatar image

OK so who is brain dead then? I had downloaded the 386 not 64bit version of LO3.5 and installed it (but got no warning I was doing something that stupid). Just spent a long time stripping the wrong version out and installed the 64 bit version. Now it works fine, detecting by jre just as it should. Oddly enough there was no option available to chose between i386 and 64 bit this time around, I just got the 64 bit by default. Discovered this because I thought re-downloading it might help.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-02-23 22:59:45 +0100

Seen: 849 times

Last updated: Feb 27 '12