Ask Your Question
0

Writer: Getting page number 1 for pages 1 and 2

asked 2015-01-02 20:59:58 +0200

einpoklum gravatar image

I'm writing this document (with the file originally having been an MS-Word .doc file) with LO Writer version 4.3.3.2. I'm using a page number field in my header, but instead of the pages being numbered 1, 2, 3, 4 they're numbered 1, 1, 2, 3. There are no section breaks or page breaks in the document.

What could be the cause of this situation, and how can I fix it?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2015-01-27 22:51:10 +0200

I had a similar problem. It kept showing a new set of numbers from page 3 when there was no section or document break. What fixed it for me was to do a field update (Tools > Update > Update All), save the document (I was using .DOCX format) and then do a reload (File > Reload). All my numbers then showed up fine. Not sure what it was but I'm just happy not to have to do it by hand. I hope this helps someone else.

edit flag offensive delete link more
0

answered 2015-01-13 18:11:42 +0200

Googly Googly gravatar image

In the status bar below you can see the page styles of the pages you have clicked. It may solve if the page styles are the same. If that doesn't work, there is workaround, not so standard but works. Copy the whole first page and paste it somewhere else at the end or in some other document for the time being. Delete anything blank on the first page so that the matter on the second page comes to the first page. Now, check the page number. Hope, the problem disappears. If yes, bring the matter of the old first page back, be careful while pasting. Paste it after the first character or word of the page which is the first page now. Delete this first character or word and retype where it was. Hit Ctrl+Enter at the begining of the word you just typed to shift the matter to the next page.
There is some hidden style with some words or paras. Hence, such a stupid thing occurs. Even if this doesn't work, copy the first two pages, paste in another document but paste as unformatted text. Copy from there and bring back where it was. You will have to arrange the whole matter again. But, a solution.

edit flag offensive delete link more
0

answered 2015-01-03 01:22:19 +0200

razon_22 gravatar image

updated 2015-01-03 01:24:35 +0200

Page styles can do that. Or it can be a compatibility issue between doc and odf formats. You can try applying the same page style to all your pages. Select all the pages by going to Edit - Select all. In the Styles and Formatting window, click on Page Styles, double click Default style. This will remove the header and page numbers. You will have to turn headers on by going to Format - Page and clicking Header, turn the header on, click Ok. Then insert the Page Number field to get the page numbering back. Do this by clicking into the header of the document, go to Insert - Fields, select Page number and Ok. The file will then need to be saved into an ODF format instead of doc.

edit flag offensive delete link more

Comments

You should save as ODF anyway before saving as anything else.

rautamiekka gravatar imagerautamiekka ( 2015-01-03 01:23:18 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-02 20:59:58 +0200

Seen: 926 times

Last updated: Jan 27 '15