Ask Your Question
0

How can Japanese writing be enabled?

asked 2015-05-04 13:21:35 +0100

ROSt52 gravatar image

updated 2015-08-26 22:09:01 +0100

Alex Kemp gravatar image

kubuntu 14.04
Lenovo Thinkpad x240
All downloaded an installed version are for 64bit machines.

I am running LIbO 4.2 8(English) from the normal kubuntu repository
I installed v4.3.7 and v4.4.2 (English) manually following the installation guideline and help I got from @karolus

In English all worked well.

Next I installed the v4.4.2 - Japanese helpfile and got the error message (marked between >>>> and <<<<):

/LibO Installation Folder/LibreOffice_4.4.2.2_Linux_x86-64_deb_helppack_ja/DEBS$ sudo dpkg -i *.deb
[sudo] password for rost: 
Selecting previously unselected package libobasis4.4-ja-help.
(Reading database ... 297177 files and directories currently installed.)
Preparing to unpack libobasis4.4-ja-help_4.4.2.2-2_amd64.deb ...
Unpacking libobasis4.4-ja-help (4.4.2.2-2) ...
dpkg: dependency problems prevent configuration of libobasis4.4-ja-help:
 libobasis4.4-ja-help depends on libobasis4.4-ja (>= 4.4.2.2); however:
  Package libobasis4.4-ja is not installed.
 libobasis4.4-ja-help depends on libobasis4.4-ja (<= 4.4.2.2-2); however:
  Package libobasis4.4-ja is not installed.
>>>>dpkg: error processing package libobasis4.4-ja-help (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libobasis4.4-ja-help<<<<
rost@rost-ThinkPad-X240:~/Downloads/LinuxSW/LibO_Ins
tFolder/LibO Installation Folder/LibreOffice_4.4.2.2_Linux_x86-64_deb_helppack_ja/DEBS$

Next (for v4.4.2)
- Installation of Japanese language pack => no error message.
- Again installation of Japanese helpfile => no error message
- Restarted PC
- Started v4.4.2 Writer
- Changing the input method to Japanese input method (IBUS Anthy)
- Typing in Writer did not work
- Checked language setting in Options; Japanese was set as Asian language (With the same setting writing Japanese on my XP machine works fine.)
- Tested Japanese writing in Kat, KMail and Mousepad. Kate and KMail worked fine, Mousepad not.

For version 4.2.8 8 (kubuntu repository) the Japanese language pack and helpfile is installed but does not work either.

What did I make wrong? What am I missing?

Note: I am a newbie in Linux.

EDIT 06-May-2015
After restoring the image root and boot image, LibO 4.2.8 is the only version left.
Checked with the package manager: Japanese language and help packages are installed.
For a test, I change the GUI language from English to Japanese, All menus seen were in Japanese, still writing in Japanese was not possible.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-05-04 15:23:20 +0100

updated 2015-05-04 18:40:42 +0100

Simple: you didn't download and thus tell dpkg to install the dependencies it requires (you could use gdebi to auto-install dependencies from repos, but that's not good idea here either), but you shouldn't do this, you should use the PPA and apt-get or aptitude to install, since you're on Debian/Ubuntu:

1) sudo add-apt-repository ppa:libreoffice/ppa

2) sudo apt-get update or sudo aptitude update (recommended)

3)

sudo apt-get install libreoffice libreoffice-accessodf libreoffice-dmaths libreoffice-help-ja libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport openclipart-libreoffice

or

sudo aptitude install libreoffice libreoffice-accessodf libreoffice-dmaths libreoffice-help-ja libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport openclipart-libreoffice

(recommended)

and add mozilla-libreoffice if you're using Firefox.

If you get complaints about conflicting packages, you need to sudo apt-get remove PACKAGE_NAMES or sudo aptitude remove PACKAGE_NAMES (recommended) them if the program doesn't automatically suggest it.


If every newer version is bad, report all this through https://bugs.documentfoundation.org/e... and try earlier versions. Here's how:

1) Add the repos for specific versions (a single line to do it automatically, you just need to hit Enter 4 times in a row with little pause in between):

sudo add-apt-repository ppa:libreoffice/libreoffice-4-2; sudo add-apt-repository ppa:libreoffice/libreoffice-4-3; sudo add-apt-repository ppa:libreoffice/libreoffice-4-4; sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases

2) List the version names for available packages (all of the packages installed above by my command, with apt and aptitude (recommended) variants):

apt-cache showpkg libreoffice libreoffice-accessodf libreoffice-dmaths libreoffice-help-ja libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport openclipart-libreoffice

aptitude versions libreoffice libreoffice-accessodf libreoffice-dmaths libreoffice-help-ja libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport openclipart-libreoffice

3) and once you know the version string, which should be the same for all packages that relate to each other closely. Those that don't closely relate to each other don't have same version string:

sudo apt-get install PACKAGE_NAME=VERSION_STRING

or

sudo aptitude install PACKAGE_NAME=VERSION_STRING

(recommended)

*) I don't know whether you can install another version to replacing previously installed version automatically, so you should

sudo apt-get remove PACKAGE_NAME:VERSION_STRING

or

sudo aptitude remove PACKAGE_NAME:VERSION_STRING

before going for another version

edit flag offensive delete link more

Comments

@rautamiekka - Thanks for reply. I need a bit more time to study your answer.

However, the problem with Japanese writing occurs also in the kubuntu repository version 4.2.8. Here all dependencies should be installed as my system is up-to-date.

I would like to first solve the Japanese writing problem with 4.2.8 and then tackle the other topics.

ROSt52 gravatar imageROSt52 ( 2015-05-04 16:41:07 +0100 )edit

@ROSt52: then we got a problem. You should report all of this to them. You can add all of the repos, then install a specific version. Check the post.

rautamiekka gravatar imagerautamiekka ( 2015-05-04 18:41:12 +0100 )edit

@rautamiekka - Thanks again for your information concerning correct installation of other versions.

To be on the safe side, I restored the image of my root and boot partition which I created before I installed v4.3 and 4.4.

Now only 4.2.8 is installed but Japanese writing does not work. Installation from the kubuntu repository. See also my EDIT of 06-May-2015 in my question.

I would very much appreciate if you could help me enabling jap. writing in LibO first.

ROSt52 gravatar imageROSt52 ( 2015-05-06 08:24:02 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-05-04 13:21:35 +0100

Seen: 818 times

Last updated: May 06 '15