Ask Your Question
0

Is it possible to adjust the scrolling speed in all LibreOffice apps?

asked 2015-05-24 02:08:21 +0200

r0ckh4mm3r gravatar image

updated 2015-05-24 02:09:40 +0200

Horizontal and vertical scrolling speeds are fast.

Within Calc: vertical scrolling jumps ~40 rows; horizontal scrolling jumps ~20 columns Within Writer: vertical scrolling jumps half a page

My goal is to make scrolling become less rapid

Operating system properties for scrolling have been reviewed. The discussed scrolling speeds do not carry over into either Chrome or Microsoft Office applications.

Please provide direction to necessary sections of coding or Option settings (although I have already done a quick review of LibreOffice Option settings)

Thank you for reviewing this topic

Nate

edit retag flag offensive close merge delete

Comments

1

Which OS are you using?

I consider that scrolling speed is controlled by your OS.

ROSt52 gravatar imageROSt52 ( 2015-05-24 07:24:21 +0200 )edit

I have just started using Libreoffice with a new Dell XPS laptop and noticed the too-fast-scrolling myself with the trackpad. I tried to upvote but since I just joined I was unable to.

RobmOz gravatar imageRobmOz ( 2016-06-26 04:44:20 +0200 )edit

LibreOffice is awesome but the most annoying feature is how poorly it handles mouse scrolling. I generally use a touchpad and scrolling is so chaotic it almost makes me want to go back to Word. I checked around the forums and the devs seem to think they fixed this bug. I do not experience this problem with any other program. It is definitely a bug with LibreOffice.

Kralicemira gravatar imageKralicemira ( 2016-09-26 08:10:20 +0200 )edit

It's 2017 & this problem persists. I just switched to LibreOffice from OpenOffice ( Windows 8.1), & scrolling speed with my trackpad is so fast it's useless: I must use the down arrow. I adjusted the trackpad settings, and yes, that slows it down, but also in all other apps where it was normal. So now those apps are painfully slow. Using an external USB mouse works fine. This must be a bug in LibreOffice, and I hope there is a developer who takes on fixing it! Thank you all for your hard work.

tamarinera gravatar imagetamarinera ( 2017-01-30 23:22:17 +0200 )edit

I recently spoke with the developer of Smooze (a configurable mouse/scroll manager for macOS) to see if anything could be done about the horizontal scroll in LibreOffice. Unfortunately, it seems that LibreOffice has its own scroll implementation which is NOT controlled by the OS. This should really be considered a serious UX/UI deficiency and should be tended to.

Winterflags gravatar imageWinterflags ( 2017-07-24 10:44:04 +0200 )edit

I'm actually having a slightly opposite issue with my El Capitan mac and LO 5.3... where trying to scroll "down" or "right" is painfully unresponsive unless I mash it. But scrolling "up" and "left" is as responsive as it is in all other apps. Clearly the scrolling implementation in LO is buggy, lacking, broken. I hope they do fix it, as its the one thing right now blocking me from bailing entirely on MSO and going to LO.

Frigidman gravatar imageFrigidman ( 2017-08-03 19:46:03 +0200 )edit

6 Answers

Sort by » oldest newest most voted
0

answered 2017-11-01 10:55:09 +0200

andy17 gravatar image

What I find annoying is that the scrollbar behaves differently from other apps on Windows 10. The scrollbar in LO seems to reflect the position in the document. So when you click below the current position marker, it moves the position in the document so that the current position marker moves to where you clicked. Similarly if you click above it. IE it behaves differently to other scrollbars on Windows 10. I think that's why it appears to move fast as it's moving the view to where you've clicked. In order to achieve anything like normality is to use the PAGE-UP and PAGE-DOWN keys. Or alternatively drag the current position marker until you see the bit of the document you want. What would be really great is if the behaviour changed to what other apps do in Windows 10 or alternatively provide an option so that people can decide how they want the scrollbars to behave.

edit flag offensive delete link more

Comments

I have a similar problem on Win 7. If I click in the scroll bar above the current position it scrolls all the way to the top (or bottom) of the document. On a Calc sheet with several hundred or thousands of rows, this can mandate a coffee break as I have to wait for the scrolling to finish because once it starts scrolling, there is no way to interrupt it. Please offer a solution.

Carrbigdog gravatar imageCarrbigdog ( 2017-11-23 04:11:13 +0200 )edit
0

answered 2015-10-11 11:50:28 +0200

lapo gravatar image

You might have a recent mouse with "Smooth scrolling" feature (or similar)… it is implemented sending much more wheel events and then scrolling less for each one on the application side, and in Chrome a plugin is installed for that effect. I know I de-activated mine because the applications response to the "new" events was not consistent and in the end I prefer to have the old "blocky" scroll which works everywhere than having "smooth" scrolling but only in a subset of applications.

edit flag offensive delete link more
0

answered 2016-12-04 17:19:47 +0200

If you are on linux (and maybe even on a mac) then this might set your scrolling speed slower (copy paste it into a terminal window):

env SAL_USE_VCLPLUGIN=gtk libreoffice --writer

It sets the environment variable 'SAL_USE_VCLPLUGIN' to the value 'gtk' and then launches libre office writer. From what I understand this changes how libre office looks and behaves on input. So it changes how it gets the mouse input and makes the speed functional.

edit flag offensive delete link more

Comments

I dont know if this will work for calc.

whatever gravatar imagewhatever ( 2016-12-04 17:22:24 +0200 )edit
0

answered 2016-03-19 02:22:37 +0200

MarjaE gravatar image

updated 2016-03-19 02:24:23 +0200

I am having the same problem in OS X. I can't use scrollwheels. Too painful. Too painful by far. I use a special scrolling app. I have reasonable scrolling speeds in other apps, but now suddenly have lightning-fast migraine-worsening scrolling speeds, and no control in LibreOffice.

edit flag offensive delete link more
0

answered 2018-11-27 21:55:50 +0200

rodrumt gravatar image

updated 2018-11-27 21:59:32 +0200

I encountered similar problem too. When I scroll down LO Calc it scrolls too fast. Three rows contain text that extends cells' height so theese cells' height is approximately equals to work area height. When I try to do minimum scroll movement, and work area jumps so the 4-th row is at the top of the work area. The issue with scroll working dependently of row height. It is very ugly behavior. Please, fix it.

edit flag offensive delete link more
0

answered 2017-09-21 18:26:09 +0200

Go to Tools > Options, and under LibreOffice, choose View. Set the Middle mouse button dropdown to Automatic scrolling. After doing this I found it was still fast but not so fast as to be unusable.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-05-24 02:08:21 +0200

Seen: 9,914 times

Last updated: Nov 27 '18