Ask Your Question
0

Libre office 3.6.4 Calc sorts column labels into data [closed]

asked 2012-08-31 21:23:15 +0200

Eliz gravatar image

updated 2015-10-19 03:05:51 +0200

Alex Kemp gravatar image

I have a spreadsheet with column headings in row 1. When I select-all and click Data>Sort, the Sort Criteria tab shows Columns A, B, etc; I click the Options tab, check in the box "Range contains column labels", click back to the Sort Criteria tab, and now it shows the column labels; I select a label, click Sort, and ALL the rows are sorted, INCLUDING ROW 1 with the column labels.

This did not happen in LO 3.4. Is it a bug? Is there something I can do to prevent it?

Having to manually select 'All but the top row' and sort by column letter is do-able but not very handy.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 03:06:07.229873

Comments

@Eliz, assume you mean LibO 3.5.4

vsfoote gravatar imagevsfoote ( 2012-09-01 10:14:12 +0200 )edit

@vsfoote, this bug is only in 3.6 series. In 3.5.4+ it works as expected.

ehansen gravatar imageehansen ( 2012-10-04 18:23:27 +0200 )edit

I have the same problem using LO 4.2.8.2 on Ubuntu. I can click "Range contains column labels", but when I sort then the first row is again sorted into the other rows. Have to say, I'm using an Excel workbook.

AndyAndy gravatar imageAndyAndy ( 2016-07-28 20:38:22 +0200 )edit

This is still a problem in Version: 5.3.6.1, Build ID: 686f202eff87ef707079aeb7f485847613344eb. Please reopen this issue

slot gravatar imageslot ( 2018-10-06 21:39:18 +0200 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2012-12-04 00:54:05 +0200

Gippy73 gravatar image

It's been solved: https://bugs.freedesktop.org/show_activity.cgi?id=53482

I've just tried with last ver of LibreOffice (3.6.3) on MacOsX and the problem doesn't come up any more.

edit flag offensive delete link more

Comments

update:

  • fdo#54160 has current status of RESOLVED DUPLICATE of fdo#53482
  • fdo #53482 has current status of RESOLVED FIXED
qubit gravatar imagequbit ( 2013-01-30 20:46:20 +0200 )edit
0

answered 2012-09-06 21:06:44 +0200

RobC gravatar image

I experience this same issue on 3.6.0.4 for Windows. I don't understand the other answer offered. Isn't the top-most row of the selection used as the column label? Either way, my column labels are in row 1 and it does not matter if I select a range of cells or select all. The column labels are still sorted into the data.

edit flag offensive delete link more
0

answered 2012-09-01 10:16:26 +0200

vsfoote gravatar image

updated 2012-09-01 11:10:10 +0200

Make the Select All (<ctl>+A) selection first, and then in Calc menus select the Data -> Sort -> Options -- "Range contains column labels" check box.

Here is the key: Column labels are not limited to Row 1, just the first row of the selected range of cells.

So, within a spreadsheet "Range contains column labels" for sorting is determined when working with a selected Ranges of cells, and again is independently determined when using the Select All. They use the same options checkbox for Column labels, but function differently, e.g. Select All is a unique set, but multiple ranges of selected cells can be sorted (and need to identify if they have column labels).

Within a spreadsheet, once set the Select All setting is statefull and remembered. But as you establish additional selected ranges you need to set sort option if "Range contains column labels" for each new range. And each spreadsheet can have multiple working ranges defined and saved with it.

The "Contains column labels" for each range of cells and the Select All case can be independently toggled.

Column label value is unchecked by default for a new spreadsheet, for the Select All case, and for each new range. Have to be careful about what range of cells or if Select All is selected for the sort operation.

edit flag offensive delete link more
0

answered 2012-09-16 12:38:14 +0200

Jean-Baptiste FAURE gravatar image

Known bug: https://bugs.freedesktop.org/show_bug.cgi?id=54160 Workaround:

  1. do not select the entire sheet but only the columns you want to sort.
  2. all sorted columns must have a header if one column has a header
edit flag offensive delete link more
0

answered 2012-09-16 08:38:24 +0200

I've got the same problem. I know how to use sort, but it is broken. I just moved from OpenOffice.org over to Libre Office. I think I made a mistake. I'm using LO 3.6.1.2.

edit flag offensive delete link more
0

answered 2012-09-12 02:25:44 +0200

ehansen gravatar image

I am pretty sure this is a bug.

Checking "Range contains column labels" makes it possible to use those labels in the drop down of which columns we want to sort by.

But there is no reason that the column label row should be sorted in with the regular rows.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-08-31 21:23:15 +0200

Seen: 10,512 times

Last updated: Dec 04 '12