Ask Your Question
0

New Page Style doesn't remember "no footer"

asked 2015-09-01 14:50:39 +0200

dazedinlibre gravatar image

updated 2015-09-01 14:59:44 +0200

Alex Kemp gravatar image

LibreOffice Writer Version: 4.4.4.3 Lang: English

I created a new page style named "NoMargin" following the directions here: https://help.libreoffice.org/Writer/C...

The new page style has no margins and I unchecked the box for footer. I created a new page with the new style. It looks fine. No margins, no footer. But after I save and reopen, the footer on this "NoMargin" page turned back on.

When going back into "Styles and Formatting", I observe that my new style "NoMargin" is gone and replaced by something called "Converted5".

"Converted4" is the style of the page before. The page after this modified page has become style "Converted6".
Not sure why it changed the name to Converted5...Anyway, all the other pages have a footer (except for the title page).

I don't want this specific "Converted 5" page (which comes in the middle of my document) to have a footer. Any suggestions how to make the "no footer" option stick on this page?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-09-01 16:07:30 +0200

petermau gravatar image

What file format are you using to save the file? It looks as if you are not using the native .odt. Try saving the file as a .odt to see whether this fixes your problem. Convert5 etc. looks as if you are importing a .docx or .doc file which does not provide equivalent style supports as provided in LibreO... hope this helps Peter

edit flag offensive delete link more

Comments

Ok thanks. Yes, I am saving this file as a .docx file because I need to pass it to someone in an MSWord format. If you discover any workaround, would love to hear it...All the margin formatting gets preserved when converting to .docx format. It's just this footer "on/off" that doesn't seem to stick...

dazedinlibre gravatar imagedazedinlibre ( 2015-09-03 14:12:00 +0200 )edit
0

answered 2015-09-01 15:28:31 +0200

Alex Kemp gravatar image

updated 2015-09-01 18:41:59 +0200

Hi dazedinlibre

Most of the time folks want a new page (or page(s) within a run of pages) to essentially be the same as all the rest, but be different in some specific way. Additionally, that specific way is often explicitly to do with the header and/or the footer of the page.

Relevant Information:

The Header & Footer of an ODT page is tied to the Page Style for that page. Any text and/or field within either will be repeated within all pages that share the same Page Style.

Note that Writer files saved in .docX (one of the ms-office format) files will not save Page Style information; the classic sign of that happening is when a Writer style gets renamed to a "convertedn"-format name such as your Converted4 & Converted5 styles (thanks to Peter Mau for the heads-up on this one).

Here is how to do what you want:-

Step-by-Step:

  1. Click on Styles & Formatting in the Side-panel
    (alternative): press F11
  2. Select 'Page Styles' + select 'Converted4'
  3. Click New Style from Selection & select New Style from Selection
    (so good they named it twice)
  4. Enter 'NoMargin' & press OK
  5. Now place the cursor at the very beginning of where NoMargin will begin.
  6. Enter: Menu:-Insert Manual Break...
    (select) Page Break
    (click on drop-down & select) NoMargin
    (press) OK

Verify for yourself that the new page has a page-style that is still called 'NoMargin'. Modify NoMargin as you wish.

If you want a chapter to be re-numbered, then you need to take slightly different steps at step 6 above:-

  1. Go (menu):FormatParagraphText Flow tab
  2. check Break + Insert and With page style
    (select 'NoMargin')
    (adjust page number as desired)

If this helps then please tick the answer (✔).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-09-01 14:50:39 +0200

Seen: 186 times

Last updated: Sep 01 '15