Ask Your Question
0

LO 3.5 - MS-word work VERY SLOW [closed]

asked 2012-02-27 18:47:23 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Dear friends: I have a Acer Aspire One, (1Gb Ram - Intel Atom), and use Lubuntu (Ubuntu 11.10).

In the past i use OpenOffice with MS-Word Files (I´m a lawyer), and works ok.

When change to LO 3.0, some MS-Word files make the software works very slow. (Write one word and need to wait 30 to 45 seconds to write another).

So, i try to solve the problem upgrading to LO 3.5, but the problem is the same.

I try to solve the problem changing the font type, the format of file (ODF, DOCX, etc), but nothing change.

If i open this files in MS-Word (Windows) works fine. (Faster).

Can someone help me please?. (I dont want to change to Micro$oft after 12 years of good work in Linux, but i can solve this problem).

I hope sombody have the answer.

Best Regards Lorenzo

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-22 02:50:14.374720

Comments

I FOUND ONE DIFERENCE: I open a document that works faster and ONLY APPEARS THE SPANISH LANGUAJE. (Not others). BUUUUT: The spell check dont work. What do you think?.

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 23:52:07 +0100 )edit

6 Answers

Sort by » oldest newest most voted
0

answered 2013-02-17 07:23:03 +0100

qubit gravatar image

Hi @pwbylmiranda,

As others have mentioned, it sounds like there might be something about the formatting of this particular document that's causing slowdown. Please let our developers know about this speed issue by filing a bug and describing the issue (including uploading the problematic document to the bug tracker). The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks

edit flag offensive delete link more
1

answered 2012-05-15 13:40:57 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

A received (fairly complex) 27 page M$ Word document was appallingly slow to navigate in LO, even after saving as .odt and re-opening it. I selected all and cleared direct formatting (CTRL+M - shortcut for Format/Clear direct formatting) and the problem went away. So did some of the formatting (like bold applied on top of a basic style), but at least I can now work on it.

(Using LO 3.3 under Ubuntu 12.04).

edit flag offensive delete link more
1

answered 2012-05-16 01:44:21 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I think the problem is that all text is only in one paragraph, and for every letter you insert or deleted, the program needs to repositioning all the text in the document. If it is mandatory have all text without breaks, try to insert some enters in coincidence with an end of line.

edit flag offensive delete link more
1

answered 2012-02-27 20:42:44 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I just looked at the document you posted. Same 'lag' effect here. Copy/paste the contents with special "unformatted text" and it is smooth. Maybe There is a formatting style that LO does not like... will need to reduce the document to the bones to figure this out.

edit flag offensive delete link more
0

answered 2012-02-27 19:22:28 +0100

Pedro gravatar image

LibreOffice works internally with ODF files. When you work with MS-Word files you are forcing a conversion at open time and at save time. In order to work more efficiently you should use ODF and only export to MS format when you need to send it to someone who doesn't use LibreOffice (or you can suggest to them to install LibreOffice for Windows... It is free after all ;) ) If the document you are sending is not supposed to be edited by the person receiving it, then you should simply export and send it as PDF.

edit flag offensive delete link more

Comments

Pedro: Even if i use ODF with some documents the problem is the same. This problem dont happend before with OpenOffice, just appear with LO 3.0 and 3.5.- How can i solve the problem?. If you give me an email i can send you a file for test.

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 19:25:08 +0100 )edit

Pedro: even if i copy all tex to a TXT file, close the MS-Word file, open a new ODT file and paste the text, the problem persist (It's a little faster, but little bloks exist. uffff.... a bad thing. I dont understand whatś happend.

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 19:36:11 +0100 )edit

Please notice that when this document is open on the status bar (bottom edge) it says Multiple Languages (shouldn't it simply say Spanish (Chile)?) Isn't it different from the other documents that load quickly?

Pedro gravatar imagePedro ( 2012-02-27 21:17:22 +0100 )edit

Says on languaje (Spanish Mexico) (I'm from Chile). I cant see the diference between this and other documents. (I'm a lawyer and almost all my documents are very similar to this one).

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 23:44:25 +0100 )edit
0

answered 2012-02-27 19:34:40 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Does the problem always occur or just when you open the document? I had similiar problem. English is not my default language for documents. I installed spellchecker for my own native language. And the problem occured. I remove the native language extension and works without any problem now.

edit flag offensive delete link more

Comments

Unfortunely the problem always occur, BUT... only with some documents. Other (even MS-Word) works fine. I think the same (the languaje problem) and disable all write aids, but no help. I will try again with languajes. Thanks. (It will be necesary "renew" my netbook?????.... someting like in windows)

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 19:50:44 +0100 )edit

Then if possible upload the document somewhere and give link here. I want to try on my minibook.

hatalar205 gravatar imagehatalar205 ( 2012-02-27 20:04:45 +0100 )edit
pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 20:16:15 +0100 )edit

I think I have found. Can you try this? http://ubuntuone.com/6Ijl0pPc5CYrZnY8...

hatalar205 gravatar imagehatalar205 ( 2012-02-27 20:26:39 +0100 )edit

hatalar205: When write "between" lines, appears the lag. But, if i write at the final of the document, or in a new paragraf, not. What do you think?

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 22:42:40 +0100 )edit

I am not a devoper but I think. As your document is long and Allignment is set to Justified, your processor is trying to locate all the words one by one on each word inserting, and this is not an easy job for an Atom processor.

hatalar205 gravatar imagehatalar205 ( 2012-02-27 22:57:26 +0100 )edit

Is a good theory, but in OPENOFFICE works fine and in MS-WORD works great in a file longer than this. How can i send this thread to developers?.

pwbylmiranda gravatar imagepwbylmiranda ( 2012-02-27 23:18:57 +0100 )edit

Sorry I have no idea.

hatalar205 gravatar imagehatalar205 ( 2012-02-28 15:37:57 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2012-02-27 18:47:23 +0100

Seen: 1,403 times

Last updated: Feb 17 '13