Ask Your Question
0

Some (one?) greek sign(s) missing in LibreOffice

asked 2015-10-03 16:34:27 +0200

arminius gravatar image

updated 2015-10-09 17:55:31 +0200

Alex Kemp gravatar image

Hallo!

I get crazy: I tried to make a greek "mue" (Physical sign for friction coeff.). No way. I tried mu, %mu, %micro, etc. In fact: %alpha works well and provides a correct greek alpha sign.

And then I searched examples: Here I found it: It's written %mu.
But also in examples I get a "%mu" and NOT the greek sign.

I tried this in LO Impress, but it's the same in LO Writer. I checked it.

And what is not funny: In the examples this is the only sign which does not work. Again an obvious bug?

Hermann Win 7 home 64.

edit retag flag offensive close merge delete

Comments

As you also used German badges you may use a keyboard of German standard layout like I do myself. There the µ (old ASCII extended code 181) is the third assignment to the "M" key got by AltGr+M. You can not get a µ from the 'Basic Greek' section of UTF tables this way.

(I placed this attempt of an answer inside a comment because it is off topic for the English branch of 'ask'.)

Lupp gravatar imageLupp ( 2015-10-08 11:02:28 +0200 )edit

Thank you! AltGr+M - the most important thing - works. And this also in math mode. OK-I see: It's also printed on my IBM-keyboard. But this trick does not work for %nu. I am not familiar with different fontsets. Nevertheless- I did not understand where the problem is and why it does not work on a simple German WIN7-system. And as I remember mu and nu is also missing on my Linux-Laptop. (Suse 13.2 64). I'll check it out.

arminius gravatar imagearminius ( 2015-10-10 17:51:02 +0200 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2015-10-09 18:21:11 +0200

Alex Kemp gravatar image

updated 2015-10-09 21:14:40 +0200

You have excellent answers elsewhere, but I thought to mention the actual Unicode letters. As long as you have a font with the glyphs within them you can use the following to assign that letter to a keyboard-combo of your choice:-

  • (menu):ToolsAutocorrect Options...Replace (press New)

The Unicode chars:

  • µ (U+00B5) MICRO SIGN
  • μ (U+03BC) GREEK SMALL LETTER MU
  • ㎂ (U+3382) SQUARE MU A
  • ㎌ (U+338C) SQUARE MU F
  • ㎍ (U+338D) SQUARE MU G
  • ㎕ (U+3395) SQUARE MU L
  • ㎛ (U+339B) SQUARE MU M
  • ㎲ (U+33B2) SQUARE MU S
  • ㎶ (U+33B6) SQUARE MU V
  • ㎼ (U+33BC) SQUARE MU W

How to Type these Chars?

It is OS-specific. I entered the chars above under Debian 6.0 by copying them from KCharSelect v1.6 (a KDE character selection utility).

In Windows you used to obtain any keyboard char by typing Alt + numeric codes (Number-Pad only):

  • Alt+xxxx (where xxxx is the numeric code point) (no preceding zero)
    (generates an OEM-encoded character)
  • Alt+<+>+xxxx (where xxxx is the hex Unicode)

The above are problematical, and may not work; Alt+letters in particular are used to access menu options, whilst Alt+numbers under Firefox are used to access Tabs. Probably the simplest method under M$ is to use Windows Character Map (charmap.exe) & copy into the clipboard.

If this helps then please tick the answer (✔)
...and/or show you like it with an uptick ()

edit flag offensive delete link more

Comments

@Alex Kemp Would you expand on how to actually access the unicode characters you list? I believe that those with just numeric values can be accessed with Alt+numerical keypad value in Windows. I don't see how to do the ones you list with letters. I did search help, but no joy. thanks

JKEngineer gravatar imageJKEngineer ( 2015-10-09 19:50:09 +0200 )edit

Yes- fully correct: E.G. the "B" always tries to access a menu under LO. In the menu Alex described there is a nu and mu as correct greek signs. They are there in the left column as :mu: and :nu: .

I am completely confused... :-( The clipboard copies bitmaps - or am I wrong? I only want to write a simple mathematical formula with mu - the friction coefficient.

arminius gravatar imagearminius ( 2015-10-10 18:30:35 +0200 )edit

@arminius: I've answered your question; do I get a (✔), or what? "The clipboard copies bitmaps": incorrect. The clipboard copies multiple MIME-types. The only one that you can be certain that it copies is 'text/plain'. In LO you can examine these multiple MIME by pressing Ctrl+Shift+V.

Alex Kemp gravatar imageAlex Kemp ( 2015-10-12 14:01:30 +0200 )edit
1

answered 2015-10-12 13:59:39 +0200

Lupp gravatar image

updated 2015-10-12 14:01:02 +0200

(Since nobody mentioned it so far:) No solution for "the computer", only for AOO, LibO!

There is an add-in/extension named 'Compose Special Characters' available via this location from the OpenOffice branch but also working (for me) in every version of LibO I tried (up to 5.0.2). I don't need/use it on a regular basis, but now and then. Someone specifically interseted in Greek letters may easily memorise and then use the special key combinations . He (f/m) will also need an additional shortcut for actually applying the replacement of the special keys by the addressed symbol. This shortcut is configurable. The special keys are not. This is a good solution judged from a technical point of view. It may not be as "handy" in every context as someone would prefer. Concerning Calc ... You will learn about that yourself.

Since the original question focussed on the "micro" sign I didn't suggest this solution till I found appended the comment by the questioner on my comment on his question.

Hope this helps.

edit flag offensive delete link more

Comments

I use this extension MANY times, EVERY day. Great add-on, IMO.

David gravatar imageDavid ( 2015-10-12 14:55:21 +0200 )edit
0

answered 2015-10-30 18:01:05 +0200

Zore34 gravatar image

It's wrong on the example. After inserting the symbol with Tools -> Catalog, I found out that the correct one is %my, not %mu.

I don't know if it's a bug, but I have LibreOffice version 4.2.8.2 and 'mu' letter is inserted into formulas as %my

edit flag offensive delete link more
0

answered 2015-10-06 19:55:13 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

yes- for shure. I am an old LaTeX man: In LaTeX I would say: $ \mu $ does not work.

Every letter (OK - I did not try each letter) works, but not %mu and %nu. Why?


OK-in another thread I ask where this window on the left is. In one of my Libreoffice Versions it vanished. I tried reinstallation of the newest LO. No way... :-(

Hermann

edit flag offensive delete link more
0

answered 2015-10-08 03:11:40 +0200

horst gravatar image

Since LO5 there are emoji symbols which are entered in Writer and Calc via Autocorrection.

Enter :mu: and you get µ if the used font supports it. Works fine with Segue UI Symbol and Segue UI Emoji (win 8.1) , but if I use Arial I get M.

edit flag offensive delete link more
0

answered 2015-10-05 17:51:01 +0200

updated 2015-10-05 17:52:17 +0200

Are you using Formula? With Formula it works.image description

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-03 16:34:27 +0200

Seen: 3,474 times

Last updated: Oct 12 '15