Ask Your Question
0

How do I get rid of clipboard-pasting-by-Enter?

asked 2015-10-13 23:44:05 +0200

sansdomino gravatar image

updated 2015-10-15 01:58:30 +0200

Alex Kemp gravatar image

An irritating feature in LO Calc — it's been there as long as I remember, still there as of version 5.0.1.2 (in English, on OS X) — is that after copying a cell or a range of cells to the clipboard, the selection becomes… "highlighted" for the lack of a better term (distinct from being selected; visually identified by an animated dashed border). After this, as long as no cells' contents have been edited, hitting Enter will paste the clipboard contents into the currently selected cell(s). This overrides both any other actions assigned for the Enter key, and the usual warning about pasting data into cells that already have content.

I have no use for this feature, and I would like to disable it, but I've so far not found anything in the documentation that as much as acknowledges that the feature even exists.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2019-09-09 13:34:26 +0200

Megawatt gravatar image

I cannot believe this feature is still there! Who sees this as a valuable feature? It has no use other than obstruct workflow. It even deletes clipoard content, so you have to undo the accidental paste and copy again what you had in clipboard.

I will probably kill this feature via AutoHotkey: When Ctrl+C sends Ctrl+C and then Escape to the LibreOffice window this strange and garbage behaviour is gone. However the borders that highlight what you have copied is gone as well.

edit flag offensive delete link more
0

answered 2018-02-21 12:23:20 +0200

Timur gravatar image

That feature is there from LO 3.3. Disable request is https://bugs.documentfoundation.org/s.... Warning issue is https://bugs.documentfoundation.org/s.... If ESC is pressed after copying, then animated dashed border (ants) is gone and Enter doesn't paste content. Options-Calc-General-Input Settings has Enter to switch to edit mode.

edit flag offensive delete link more
0

answered 2019-06-10 14:11:49 +0200

hi just today 10th June 2019 (!) switched from OpenOffice to LibreOffice AND I realize in Calc that this bad feature of pasting with the enter key IS STILL THERE !!! (these bug reports above (Bug 34686 and Bug 39531) are dating back to 2011 !! – So why do the LibreOffice developers/software programmers do not implement a check box in "Preferences..." > "LibreOffice Calc" > "General" allowing to "Disable paste with Enter key" ????? It would be great if the users themselves could just choose which bevavious of the enter key they like ! Thanks !

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-13 23:44:05 +0200

Seen: 278 times

Last updated: Sep 09