Ask Your Question
0

Problem with encoding "Link to external data..."

asked 2015-10-19 06:41:40 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I’m using libreoffice 5, every time I insert any Persian web pages with 'Link to External Data…', The 'character encoding' fails. I tested all languages but no one could help me! What should I do?

This is one of Persian web pages

Please test it and help me!

Thank youimage description

image description

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-02-10 03:03:52 +0200

I have a similar problem (but with linking to named cells in different *.ODS files - all in English). Within this past week I migrated from MS Ofc 2013 (on Win 7) to LibreOffice 4.x (on Ubuntu 14.04) and first saw the issue there (v4.x); today I updated to LibreOffice 5.0.4.2 and experienced no improvement of any kind.

Back on April 10, 2015 AllanR answered this question in an Ask.LibreOffice.org question entitled "Calc- problem linking to data in another spreadsheet;" however, I have not seen LibreOffice correctly link the data as described in the details of that reply: the menu functions correctly open; the browse function allows for file search and selection; the "Available Tables/Ranges" field fully populates with the names associated with the selected file; however, my selection of the "OK" button consistently yields only "=SUM(H#REF!:H5)" in my target cell.

Also, all of my spreadsheets come from MS Ofc 2013, so I just created two new spreadsheets using LibreOffice Calc v5.0.4.2 to test for possible issues with converted .xlsx files; the first file (named Data Link - Source.ods) contains a single column of three numbers summed, and I named the summed cell (with a value of 90) "Test01"; the second file (named Data Link - Target.ods) contains only one populated cell (into which I have attempted to link the named cell from the Source file). Before attempting to link Target to Source, I saved both files. When I use the Insert > Link to External Data menu function, Calc inserts only the cell formatting and formula (but relative to its placement in the Target sheet) from the link Source file - the value 90 does NOT appear in the Target cell, and the cell name Test01 does NOT appear in the formula created by the "Link" function.

Perhaps I'm missing something very simple - like a "Link-On" switch hiding somewhere in LibreOffice.

I would GREATLY appreciate clarification/accurate instruction/code correction/magic to resolve this issue because I have an abundance of cell-named links to repair and activate.

Thank you to all who help resolve this issue.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-19 06:41:40 +0200

Seen: 415 times

Last updated: Oct 19 '15