Ask Your Question
0

Documents open in background - LO doesn't take focus (Win 7).

asked 2015-11-16 17:49:14 +0200

ABK gravatar image

updated 2015-11-17 14:03:52 +0200

Alex Kemp gravatar image

I just installed the latest stable version of Libreoffice 5 on Window 7 64bit (British English). If I open a .odt document when LO is already running, the new document does not take focus. It isn't minimised, it just appears behind the current window and has to be selected from the taskbar.

Searching, I can find old bug reports of this problem, but no recent solutions. Is there a solution?

edit retag flag offensive close merge delete

5 Answers

Sort by » oldest newest most voted
0

answered 2016-01-14 11:13:41 +0200

updated 2016-02-04 13:47:25 +0200

Just to say that removing the sidebar seems to have solved this issue for me with Writer and Calc. I moved any sidebar buttons I needed to the upper or lower bar and LW and LC now take focus when I open a document. HTH.

EDIT: After a few weeks trial, just wanted to say that this hasn't completely solved the problem. LW docs take focus most of the time when I open them, but not always. Can't see any pattern in which ones take focus or not, unfortunately (I just opened four documents from the same folder - three took focus, one didn't).

edit flag offensive delete link more
0

answered 2015-11-17 12:00:20 +0200

pierre-yves samyn gravatar image

Hi

You're right, several bugs have been reported. It seems that to date, according to this one, there is still no correction, sorry.

Regards

edit flag offensive delete link more

Comments

Add your complain to the bug. It might help to jump a dev to take it.

horst gravatar imagehorst ( 2015-11-17 18:59:01 +0200 )edit

Please never give nor follow such advises. Bugzilla isn't for flash mobs. It must be used for constructive discussion.

Constructive is:

  • Add a relevant comment with previously missing information.

  • Add yourself to CC list (devs sometimes look at CC number to estimate how many users are affected)

Not constructive is:

  • filling the issue with "me-too"-style comments

  • bashing on devs there (both just make it hard to find relevant info and lower chances to get dev work on it)

Mike Kaganski gravatar imageMike Kaganski ( 2017-02-16 03:58:48 +0200 )edit
0

answered 2017-02-15 19:53:49 +0200

wootowl gravatar image

updated 2017-02-15 22:57:59 +0200

I'm having this bug on Windows 7 in LibreOffice 5.2.

I found a workaround for this using DisplayFusion (I use this for taskbars on multiple monitors already so figured I'd try it and it worked)

Here's my solution:

  • In DisplayFusion Settings go to "Triggers (Window Location)", make sure Triggers are enabled
  • Add a new trigger for Event: Window Created
  • In the Window Class field put this text exactly: "SALFRAME""SALSUBFRAME"
  • Under Actions add "Run Function" and select "Toggle Window Always On Top". Add this Run Function/Toggle Window Always On Top Action 2 times (toggling the window "on top", then toggling it off "on top" thus forcing it to have focus)
  • Apply the trigger and it should be working now!
edit flag offensive delete link more
0

answered 2015-11-23 15:16:28 +0200

I've found this sort of issue as well (using Win7 32 bit). I've found that if I have the Sidebar open, but undocked, it works as I would expect.

I've posted a bug report on this. See Bug 96011.

Would be good to hear if the Sidebar "workaround" does it for you (and others).

edit flag offensive delete link more
0

answered 2017-02-15 20:20:50 +0200

updated 2017-02-15 20:24:04 +0200

The bug has been fixed for 5.3 and 5.2.6.

Also, comment 50 to that bug tells the workaround that may be applied to any affected version, that only requires to change one setting in LO:

Btw you can also apply the fix by going to Tools->Options->Advanced->Expert Configuration. Search for 'ForceFocusAndToFront' and double click to change it to 'true'.

This should work in all affected versions.

edit flag offensive delete link more

Comments

1

ForceFocusAndToFront = true did not completely work for me unfortunately. When I open a CSV file (or similar) and it first pops up with a window asking how to do the import, that window still remains in the background. New windows that open up without that initial dialog seem to be ok however, but the ones that have that dialog are still problematic. For now, my DisplayFusion workaround seems to be working for all windows including the dialog window.

wootowl gravatar imagewootowl ( 2017-02-15 22:09:35 +0200 )edit

Thank you! Updated the bug with your information.

Mike Kaganski gravatar imageMike Kaganski ( 2017-02-16 03:51:59 +0200 )edit

Thanks. I just upgraded to LibreOffice 5.3.0.3 -- they mentioned on that bug page that this is now "fixed" but it isn't. The same problem I've outlined here is still happening in 5.3.0.3

wootowl gravatar imagewootowl ( 2017-02-16 16:42:08 +0200 )edit

If you upgrade, it will not be active: it doesn't change active settings

Mike Kaganski gravatar imageMike Kaganski ( 2017-02-16 17:04:18 +0200 )edit

so I'd need to uninstall, remove appdata, reinstall?

wootowl gravatar imagewootowl ( 2017-02-18 15:41:59 +0200 )edit

@wootowl: you've mentioned earlier that setting ForceFocusAndToFront didn't help you to fix this entirely. So I see that your profile has it set explicitly (unlike "clean" configuration that hasn't it set). So, as the setting isn't changed in config by the patch, just default is changed, then your specific case would stay as it was.

You may either reset it to default, or (if you prefer) just clean profile. No need to additionally reinstall.

Mike Kaganski gravatar imageMike Kaganski ( 2017-02-18 16:10:05 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-11-16 17:49:14 +0200

Seen: 1,748 times

Last updated: Feb 15 '17