Ask Your Question

[Writer] How to suppress formatting samples in Styles & Formatting window? [closed]

asked 2015-11-16 18:03:45 +0200

ajlittoz gravatar image

updated 2015-11-18 15:42:54 +0200

Styles & Formatting window in LO 5.0 displays a preview of the advertised style as well as in the Styles and Font drop-down menu.

Since I work mainly with customised styles (from a template document), I know which style I want to use. In this particular case, I do not need visual clues for choosing the style. My style names are also semantically significant to mark up the text. (Note: the semantic aspect is of prime importance for me, much more important than visual aspect. Since aesthetically acceptable variants are rather limited, two different semantic mark up may end up with same visual aspect.) The inconvenience, here, is preview takes relatively a lot of space, resulting in fewer styles being listed, leading to scroll first with the mouse before double-clicking.

The Font drop-down menu can be controlled from Tools->Options->LO->Display to enable/disable preview display. I have not found the equivalent setting for the Styles & Formatting window, albeit I explored thoroughly the Options and right-clicked in the S & F window.

Is there a feature to suppress the preview in the Styles & Formatting window in order to have a compact list?


I checked the other components (Calc, Impress, Draw) which display no preview but share the inconvenience (in my case) of too much vertical spacing between style items. Consequently, the side question is "how to customise this vertical spacing?"

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ajlittoz
close date 2015-11-17 14:52:54.559715


@ajlittoz Reopened. Have another go!

Alex Kemp gravatar imageAlex Kemp ( 2015-11-17 14:50:12 +0200 )edit

Thanks, but it was not necessary.

ajlittoz gravatar imageajlittoz ( 2015-11-17 14:52:20 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2015-11-17 08:19:42 +0200

pierre-yves samyn gravatar image


Yes, Tomaž Vajngerl developed an option. The previews can be disabled in:

ToolsOptionsLibreOfficeAdvancedExpert Configuration

by setting the property /org.openoffice.Office.Common/StylesAndFormatting Preview to false.

Note: if the styles window were displayed when editing option, you will need to refresh, for example by displaying the navigator.


edit flag offensive delete link more



That feature is impressive! Just like an iceberg: 10% (or less) adjustable through the UI, 90% for developers. But what a mess!

ajlittoz gravatar imageajlittoz ( 2015-11-17 10:26:08 +0200 )edit

To make it a bit clearer: The "Preference name" is just "/org.openoffice.Office.Common/StylesAndFormatting"; the "property" is "Preview"; the value is to be set "false". Don't concatenate these...

einpoklum gravatar imageeinpoklum ( 2015-12-13 13:28:18 +0200 )edit

Somehow, despite the fact that the property is set to 'false' in my case, I can still see the preview of styles in the dropdown menu. (The problem is that the preview causes the toolbar to dislocate/jump from its position, or so I presume.)

datka gravatar imagedatka ( 2020-12-02 09:37:35 +0200 )edit

@datka: what is your LO version?

Versions released since this question now include a check box in the style sidepane (F11 if not visible). I have not tested if the advanced setting is still necessary because the checkbox in the UI is very handy.

ajlittoz gravatar imageajlittoz ( 2020-12-02 09:58:17 +0200 )edit

Question Tools

1 follower


Asked: 2015-11-16 18:03:45 +0200

Seen: 190 times

Last updated: Nov 18 '15