Ask Your Question
1

LibreOffice completely ignores Linux input method (fcitx)

asked 2015-12-22 23:44:10 +0200

Digital bear gravatar image

updated 2016-03-11 15:41:36 +0200

Alex Kemp gravatar image

I am having trouble with entering non-latin text into LibreOffice via XIM in Linux.

When activating Linux input method (for example, to enter Pin Yin), LibreOffice completely ignores provided input.

Expected behaviour: LibreOffice should show text as composed by fcitx, such as Canadian Syllabics or Chinese, etc

Actual behaviour: Keystrokes go directly into LibreOffice, by-passing input method.

Environment:

  • LibreOffice 4.2.8.2
  • Kubuntu (Ubuntu 14.04.3 with KDE 4.13.3)
  • LANG=eo.UTF-8
  • XMODIFIERS=@im=fcitx
  • Both LibreOffice and fcitx are as
    installed by the operating system
    install process.
  • input method works everywhere else
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-01-03 09:32:37 +0200

oweng gravatar image

Possibly related to bugs tdf#82907 and tdf#85795.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-12-22 23:44:10 +0200

Seen: 985 times

Last updated: Jan 03 '16