Ask Your Question
0

Ctr alt doesn't work for special characters

asked 2016-01-27 10:31:22 +0200

Laurens_V gravatar image

updated 2016-03-10 12:19:08 +0200

Alex Kemp gravatar image

In Writer of LO 4.X I could use ctrl+alt+s for ß, ctrl+alt+5 for €, but in Writer LO 5.0.4 this functionality has been removed/overruled? Strange, since in other programs on my Windows 7 like Notepad (or in y browser) it just works. And also in Calc it just works fine. Have I missed a setting??

For the moment I have 'solved' this problem by removing 5.0.4 and reinstalling 4.4.7.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2016-01-27 17:09:31 +0200

petermau gravatar image

updated 2016-01-28 13:56:52 +0200

Not a direct answer to your question, but a possible bypass which available to all programs on the system.

However: There is a new bug 97370 on bugzilla - "System=level definition of Ctrl+Alt+letter key combination on Polish (PLP) keyboard ignored by Writer" This appears to be your problem. If you have some further information that would be very useful in helping fix your problem.

If you are using a standard keyboard, the alr gr (to the right of the space key) give access to many accented characters providing it has been defined in your operating system. On my system I frequently need to switch between English, American, French, Swiss/French and Swiss/German and use accented characters. For example, to type áéßçúû€ directly using altgr with aescu^4 etc.

The keyboard layout will display the keys available. You do not normally need macros just to type accented characters.The difference is that alt gr is keyboard specific and supported by the operating system. ctrl + alt is leftover from the time before the alt gr key arrived on the keyboard and is software application dependant. My advice is to migrate to alt gr if it is possible on your system..Peter

edit flag offensive delete link more
0

answered 2016-01-27 21:51:15 +0200

horst gravatar image

As @petermau mentioned the AltGr or right Alt should have the same function as Ctrl+Alt. I am using the US-International keyboard that gives me all accented characters and umlaute but I use only AltGr so I didn't recognize it at first.

While playing around I noticed that Ctrl+Alt+C inserts a comment in Writer instead of © /¢. This might be the reason that it is broken in LO5.0.4.

edit flag offensive delete link more
0

answered 2016-01-28 09:31:48 +0200

Laurens_V gravatar image

Thank you for your answers. I am using a US-International keyboard on a Dutch operating system. Alt Gr seems to work, also in other programs. I have never used that button before. Problem solved, I only need to get used to using Alt Gr now... ;)

edit flag offensive delete link more

Comments

Glad to help you.

horst gravatar imagehorst ( 2016-01-31 19:32:03 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-01-27 09:28:53 +0200

Seen: 526 times

Last updated: Jan 28 '16