Ask Your Question
2

large numbers truncated in Calc [closed]

asked 2012-10-03 20:29:26 +0100

ciccio70 gravatar image

I have a csv file where large numbers are stored. When I open the file in Calc, it somehow alters the numbers so that the trailing 7 digits are replaced by 0's. For example, 9400111201080133911953 shows up in Calc as 9400111201080130000000. how can I fix this?

thanks, franc

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-18 04:25:13.895531

2 Answers

Sort by » oldest newest most voted
4

answered 2012-10-03 23:34:18 +0100

m.a.riosv gravatar image

In the import window, click the column head to select it, and after select Text in the Column type.

image description

edit flag offensive delete link more

Comments

Better than my answer

w_whalley gravatar imagew_whalley ( 2012-10-04 01:47:12 +0100 )edit
2

answered 2012-10-03 21:29:08 +0100

w_whalley gravatar image

LibreOffice is recognizing the string 9400111201080133911953 as a number, but has insufficient precision to represent this number. If you can arrange to have your csv string be quoted, "9400111201080133911953", and choose the Quoted Field as Text option when the CSV is imported, it will display all the digits in the string. Alternatively you could prepend a ' to the string in the CSV, i.e. '9400111201080133911953, it will be recognized as text.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-10-03 20:29:26 +0100

Seen: 3,749 times

Last updated: Oct 03 '12