Ask Your Question
0

Calc 5.0.5 ignores Trusted File Locations for macros [closed]

asked 2016-03-04 16:23:58 +0200

Voluminous gravatar image

updated 2020-08-02 14:18:51 +0200

Alex Kemp gravatar image

I created an .ods file with some macros in it, but LibreOffice tells me they are disabled for security reasons when I try opening it again. Fair enough, but when I go to Tools->Options->Security->Macro Security and add the directory containing the file in Trusted Sources, and try opening it again, the macros are still disabled... Security level is set to high, and I would prefer not to lower it.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-02 14:19:19.663728

Comments

It is very strange. I purposely set the security level in the Versions 5.0.4.2 and 5.1.0.3 to Very High - macro of documents from the Trusted Sources work properly. Try to rename the User Profile folder - perhaps an error lurks there.

JohnSUN gravatar imageJohnSUN ( 2016-03-05 19:09:51 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-03-07 21:37:20 +0200

Voluminous gravatar image

updated 2016-03-07 21:38:55 +0200

Thank you, JohnSUN! I didn't need to rename the User folder, it was just a silly mistake on my part - I only added the real path to the trusted locations, but I usually get there using a symbolic link. Now that I've trusted the shortcut path too, the macros work!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-03-04 16:23:58 +0200

Seen: 256 times

Last updated: Mar 07 '16