Ask Your Question
1

‪How can spell checker "English, OED spelling (UK)‬" be installed?

asked 2016-03-09 09:52:24 +0200

bee_zu gravatar image

I would like to use the spell checker labelled "‪English, OED spelling (UK)‬". However, it is not clear to me how it can be installed. I didn't find any extension on the official extensions page. With Google, I found this: http://www.libreoffice-na.us/English-... Here, I could download an extension labelled "English-British en-GB-oed 2005-06-13". I installed it, but it doesn't seem to work. (The green check mark does not appear next to "‪English, OED spelling (UK)‬".) Any help and suggestions are appreciated.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2016-03-09 16:52:37 +0200

mw gravatar image

Not a solution, but a confirmation of your finding. The dictionary en-GB-oed is not recognized by LibreOffice (4.4.6.3).

I believe that there are some 'hacks' which involve replacing the existing UK dictionary with the OED version, but I don't find that approach satisfactory. I need access to both variants.

'Under the hood' there does seem to be some support for language variants, i.e. en-GB-oed as opposed to en-GB, but as there seems to be no way of having LibreOffice recognize the en-GB-oed dictionary, that support is useless.

For this reason, as a Mac user, I am transitioning to Apple's 'Pages' app. If you are also a Mac user, then it is worth knowing that if you copy the relevant files [1] into ~/Library/Spelling, the OED dictionary becomes available in the Mac's system spell checker.

And I remark that although LibreOffice seems to support the Mac's spell checker, it still doesn't see the en-GB-oed dictionary !

[1] en_GB-oed.dic & en_GB-oed.aff

edit flag offensive delete link more
0

answered 2016-03-09 13:20:27 +0200

petermau gravatar image

The English dictionary extensions are normally included in many versions of the LibO package. What version of LibO, language, system are you using. Are you just after English_GB spell checker or the OED in particular? With some language versions the English set of dictionaries is provided, as are the French and Spanish sets. The OPTIONS > LANGUAGE SETTINGS > LANGUAGE > Default Language will give a list of those languages and versions installed.

I use the EN_GB language pack and help pack in addition to the basic LibO (Linux .deb version), Windows works slightly differently. This gives the GB dictionary. However, the EN dictionary set included is the same as the base system. I used to have the OED version some time ago, but I thought that had been superseded by the LibO packaged version...Peter

If your LibO version does not include the English dictionaries, you can install the Language dictionaries by using a language pack from http://www.libreoffice.org/download/l...

edit flag offensive delete link more

Comments

I have installed LibreOffice 5.1.0.3, Locale: en-GB (en_GB) / Windows 7 and Ubuntu Spell checkers for several national varieties of English (US, UK, Canada...) are preinstalled.

I would like to use the en_GB-oed spell checker in particular. I had noticed that the option "English, OED spelling (UK)‬" is listed in the dictionaries drop-down menu, and now I would like to install it, but apparently it does not work, as confirmed in the answer above...

bee_zu gravatar imagebee_zu ( 2016-03-09 22:24:08 +0200 )edit

In LO 4.4.6.3 the "English, OED spelling" option is not listed in the Language drop-down under "Tools|Spelling & Grammar". I see you are using LO 5.1.0.3, so perhaps matters have changed. Or perhaps you are referring to a different dictionary drop-down menu.

Nevertheless, in LO 4.4.6.3 it is possible to set the Language of a text selection to "English, OED spelling" under "Tools|Language". But, as I remarked, that is useless because the dictionary is not recognized.

mw gravatar imagemw ( 2016-03-10 22:20:45 +0200 )edit
0

answered 2016-03-11 22:39:40 +0200

I'm afraid not an answer.

I was running an older version of Libre Office (5.0.?) but was advised that 5.1 would have the spell checker issue resolved. Even after installing a reasonable looking ext for a dictionary and checking the settings ( Tools | Options | Languages Settings ) and all the sub menus for British English isn't still not picking anything up.

Commenting to keep tabs on this, I've used Open and Libre Office as reliable alternatives to Microsoft for years but this is making me reconsider.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2016-03-09 09:52:24 +0200

Seen: 616 times

Last updated: Mar 11 '16