Ask Your Question
0

How can i fix Problem about Vowels Thai Font

asked 2016-03-12 06:08:05 +0200

shiyada gravatar image

updated 2016-03-12 06:08:54 +0200

I have Problem about Vowels Thai Font. example Problem in this link (Picture Problem link)

i set option Font (Picture i Set 1) and Language [ Locale setting >> thai , complex text layout >> thai (Picture i Set 2) ] but can't fix this problem. My Windows's windows 8.1 and My LibreOffice's 5.1.0.3

How can I fix this problem?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-08-30 13:00:21 +0200

Hi

I can tell you that I add this bug on Spreadsheet today on version 5.2. After multiples tests, I have to reinstall version 5.0.2.2 (which I have on another laptop and is working), and the problem disappeared.

For information this bug does not affect Writer.

Philippe, windows 10.

edit flag offensive delete link more
0

answered 2016-03-23 14:01:01 +0200

w2016 gravatar image

Please update to the latest version (5.1.1.3)

Then try Tools/Options/View and UNcheck "Use OpenGL for all rendering (on restart)"

(You have to restart LibreOffice)

Option 1: using an older version (initially I went back to 4.4.5.2, because I still had the install file; you can get other old versions from https://downloadarchive.documentfound...)

Option 2: temporarily install MS Office, install LibreOffice 5.1.1.3, uninstall MS office (this worked for my co-worker today, but IMO is not a real solution)

Some details: I had the problem with scalc from version 5.1.1.3 64 bit (on Windows 8.1); the Thai consonants were shown (the initial 5.0 version on my co-worker's computer didn't display any Thai characters), but the spacing was uneven for most fonts if I had at least one English character in front of the Thai text in the same cell; (Arial Unicode MS had proper spacing all the time for the Thai consonants); but the wrong vowels were displayed with all fonts and they were at the wrong place too.

For testing I switched to Thai input and keyed in "dbf", which should look like this: "กิด" But the "b" instead of showing the Thai vowel for a short "i" displayed the long "i" and off to the right by several consonant widths. The last character (a consonant) was properly shown. It looked roughly like this: "กด ี"

I downloaded the "Noto Sans Thai" font as suggested in another thread, but it didn't help.

I also downloaded the free MS Excel viewer and installed it in the hopes it would have the same effect as the temporary MS Office install on the other computer, but it didn't. (Additionally installing the MS Word viewer and the MS PowerPoint viewer didn't help either.)

Please note: I tried the OpenGL settings AFTER I installed all those MS viewers. So I uninstalled all 3 viewers and LibreOffice then had the option checked again! Unchecking it and restarting LibreOffice once more helped - I did not restart the computer.

HTH

edit flag offensive delete link more

Comments

Today I noticed that the weird spacing with English/Thai still was there for all fonts except Arial Unicode MS; to expand my example from above, "กิดA" is shown normally, but "Aกิด" is shown as "Aกิ ด", the problem happens with all lifted vowels and the tone modifiers.

w2016 gravatar imagew2016 ( 2016-03-24 03:21:51 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-12 06:08:05 +0200

Seen: 940 times

Last updated: Aug 30 '16