Ask Your Question
1

Remove <style> element when cut from Calc and pasted into another application [closed]

asked 2012-03-01 00:27:56 +0200

Enetics gravatar image

updated 2013-01-20 21:46:01 +0200

qubit gravatar image

When I create tables in Libreoffice Calc and paste them into Thunderbird it includes a <style> element which changes the entire message's CSS. The big problem is the "font-size: x-small" at the end. This is what is included when pasting:

<style>body, div, table, thead, tbody, tfoot, tr, th, td, p { font-fa=
mily: "Arial"; font-size: x-small; }</style>

Is there a way to change those attributes so all cut'n'paste is the same, or to not include it altogether.

Specifically, this is a problem in Thunderbird Email. When a table is pasted into an email, the <style> element is included which changes the CSS for the entire email. It can be removed manually, but it is a cumbersome process that I'd rather avoid.

Thanks for any help!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-22 00:48:03.450680

3 Answers

Sort by » oldest newest most voted
0

answered 2013-02-16 05:27:17 +0200

qubit gravatar image

Hi @Enetics,

Per @dsiegel, it looks like multiple people are experiencing this issue. Please file a bug about this problem. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
0

answered 2012-04-11 17:04:56 +0200

I also have had this problem with recent releases of TBird. Using Cntrl+Shift+V as suggested does not work -- it pastes the table without any formatting which renders the presentation of the info useless to the recipients of my daily report.

My workaround is to first type enter a few times, then paste my Libre Office Calc table before the last return character, then delete the return character immediately after the table. This reverts the style of the message and table back to the original stylesheet.

This is an annoying bug that will hopefully be fixed.

edit flag offensive delete link more
0

answered 2012-03-10 10:48:54 +0200

Try to insert the cells with Strg. + Shift + V instead of Strg. V.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-03-01 00:27:56 +0200

Seen: 566 times

Last updated: Feb 16 '13