Ask Your Question
0

Error compilation loolwsd

asked 2016-05-25 15:27:03 +0100

koalas gravatar image

I can compile loolwsd with 2 options but doesn't work

./configure --enable-silent-rules --with-lokit-path=../core/include --with-lo-path=/etc/officeonline --enable-debug

.... checking dependency style of g++... gcc3 checking for gcc... (cached) gcc checking whether we are using the GNU C compiler... (cached) yes checking whether gcc accepts -g... (cached) yes checking for gcc option to accept ISO C89... (cached) none needed checking whether gcc understands -c and -o together... (cached) yes checking for setcap... /sbin/setcap checking whether to run tests against a LibreOffice... configure: error: LibreOffice install looks dodgy, missing /var/www/officeonline/program/versionrc

./configure --enable-silent-rules --with-lokit-path=../core/include --enable-debug

.... checking for gcc option to accept ISO C89... (cached) none needed checking whether gcc understands -c and -o together... (cached) yes checking for setcap... /sbin/setcap checking whether to run tests against a LibreOffice... no checking for library containing dlopen... -ldl checking for library containing png_create_write_struct... -lpng checking for library containing cap_get_proc... -lcap ./configure: line 16234: syntax error near unexpected token CPPUNIT,' ./configure: line 16234:PKG_CHECK_MODULES(CPPUNIT, cppunit)'

Have you a idea ? Thanks

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2017-03-24 13:14:18 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The solution was to apt-get install pkg-config

edit flag offensive delete link more
0

answered 2016-10-27 21:38:13 +0100

havard gravatar image

Did anyone figure this out? I am struggeling to configure loolwsd with the error code:

$ ./configure --enable-silent-rules --with-lokit-path=../../core/include --with-lo-path=../../core/instdir --enable-debug checking for library containing png_create_write_struct... -lpng checking for library containing cap_get_proc... -lcap ./configure: line 16341: syntax error near unexpected token CPPUNIT,' ./configure: line 16341:PKG_CHECK_MODULES(CPPUNIT, cppunit)'

I have libcppunit and libcppunit-dev installed:

$dpkg -l | grep cppunit ii libcppunit-1.13-0:amd64 1.13.2-2 amd64 Unit Testing Library for C++ ii libcppunit-dev 1.13.2-2 amd64 Unit Testing Library for C++

any help??

edit flag offensive delete link more
0

answered 2016-05-26 08:07:54 +0100

koalas gravatar image

updated 2016-05-26 08:10:09 +0100

HI the cppunit pakage is installed

un cppunit <aucune> <aucune> (aucune description n'est disponible) ii libcppunit-1.13-0:amd64 1.13.2-2 amd64 Unit Testing Library for C++ ii libcppunit-dev 1.13.2-2 amd64 Unit Testing Library for C++ un libcppunit-doc <aucune> <aucune> (aucune description n'est disponible) ii libcppunit-subunit-dev 0.0.18-4 amd64 SubunitTestProgressListener for CPPUnit - Development headers ii libcppunit-subunit0:amd64 0.0.18-4 amd64 SubunitTestProgressListener for CPPUnit - C++ shared library

apt-get install cppunit Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait Package cppunit is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: libcppunit-doc libcppunit-dev

E: Package 'cppunit' has no installation candidate

edit flag offensive delete link more
0

answered 2016-05-25 15:48:05 +0100

vmiklos gravatar image

Looks like the cppunit development package is not installed.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-05-25 15:27:03 +0100

Seen: 994 times

Last updated: Mar 24 '17