Ask Your Question
0

MS office file formatting messed up by LO

asked 2016-05-28 10:49:48 +0200

arkadian gravatar image

Hi there, I know this question has been asked a gazillion times, but I hope that over time someone has come up with some trick I don't know about...

I have a word file I need to work on. The file was not created by my, but by someone else in my organization (probably with some version of Word), who knows where or when. If I open it from work (PC with word) it is fine. When I open it from home (Mac with LO) it most certainly it isn't. I already had this problem in the past and last time I had to ask HR to send me a more suitable file and they obliged.

Is there ANYTHING at all I can try or do I have to go through all this palaver again? Is it possible that all the blame is on their side and none on mine?

edit retag flag offensive close merge delete

Comments

(1) What file format has the document? doc, docx or ...? (2) You need to describe the "mess" in more details. (3) Do you have installed the fonts, which are used in the document? (4) Please write a bug report for each problem. Please reduce the document to have only this one problem (if possible) and attach it to the bug report.

Regina gravatar imageRegina ( 2016-05-28 16:52:03 +0200 )edit

Hi Regina, difficult to describe (especially because I don't have the "right" doc to compare it with). In a nutshell, the doc is made of tables with a coloured background that are supposed to be filled in (it's some kind of application form). The problems are: 1) the background has shifted, meaning, say, the left hand side of the "coloured" boxs are white and the right hand side of the other white boxes have some colour.

arkadian gravatar imagearkadian ( 2016-05-29 12:36:31 +0200 )edit

2) There is text in the box, but you cannot see it all. The boxes are too small, so a little arrow appears to alert you that there is hidden text. The problem is that the same text is not hidden when you open the doc using a different computer. It must be the spacing between the lines that changes (the font is Times). Ah, I am talking about a docx, but I don't remember which version.In any case the problem appears when you open it, not when you save it.

arkadian gravatar imagearkadian ( 2016-05-29 12:38:42 +0200 )edit

(5) How much of the text is missing? You can likely see the whole text, when you switch to View > Web. (6) Can you provide such a file. Then I can tell you more about the reasons and might find ways to tweak it.

Regina gravatar imageRegina ( 2016-05-29 17:17:46 +0200 )edit

Web layout made no difference... This is a screenshot... The background should be within the box and the text shold finish at the end of the box, instead it carries on for another paragraph. Does it help at all?

arkadian gravatar imagearkadian ( 2016-05-29 18:39:03 +0200 )edit

No, a screen shot is not enough. I need a document. Please read https://wiki.documentfoundation.org/Q.... But do not use "In the Search for field put "." (a single period)" . But put [:alnum:] in the search field. That way spaces and punctuation marks are preserved. That way wrapping is preserved. From the screen shot I guess it is the problem of importing floating tables as table inside frame.

Regina gravatar imageRegina ( 2016-05-29 19:29:50 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-05-28 19:29:09 +0200

irongron gravatar image

updated 2016-05-28 19:54:51 +0200

This may help. Go to "Preferences" in LO. Then go to the "Load/Save" section and in there go to "Microsoft Office". In there you have some options to "Load and covert" documents and to "Save and convert" as well. In "WinWord to LibreOffice Writer or reverse" uncheck the [L] and [S] columns (L is for Load S for Save). I did that on my LO Vanilla installation on my Mac and I don't have any problems with Word docs. Also in the "General" section in "Load/Save" you might want to change the "Always save as" section for "Document type" Text documents to the appropriate version of Word those docs you are working on were made in so that when you send them back they can open them in Word and the formatting is appropriate for their version of Word. I have mine set to "Microsoft Word 2007-2013 XML" but you can choose the other earlier versions to suit your Word doc versions. Also on your Mac, it's easy to determine what version of Word the doc was made in. Go to "Finder" and change the view to "List view" (in the icon bar in finder it's the second icon on the left after the < > arrows that looks like lines above one another) then locate the folder where you have the Word doc or docs and look in the "Kind" Column. There it will tell you what Word version the doc or docs are (Word 97, Word 2007 etc). Anyway give it a try and see what happens. Good luck!

edit flag offensive delete link more

Comments

Thanks for the interesting info, but alas it has made no difference :( The tip on the "file kind" is great, though I never thought of looking there...

arkadian gravatar imagearkadian ( 2016-05-29 13:33:43 +0200 )edit
0

answered 2019-03-06 03:45:47 +0200

Try opening in Google Docs. I see to have better luck with that format.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-05-28 10:49:48 +0200

Seen: 7,676 times

Last updated: Mar 06