Ask Your Question
0

Can I load an old version for my mac 10.7.5?

asked 2016-06-01 05:25:56 +0100

Can I load an old version for my mac 10.7.5?

THANK YOU

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-06-02 04:56:36 +0100

irongron gravatar image

Yes you can. According to the System Requirements page at link text "LibreOffice 4.3 can still run on OS X 10.6+, but please understand that this support will end when 4.3 is retired on May 27, 2015."


So here you go, you can get v4.3 here for OSX 10.7 link text

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-01 05:25:56 +0100

Seen: 73 times

Last updated: Jun 02 '16