Ask Your Question
0

Is there any way to default to a correct apostrophe? [closed]

asked 2016-06-03 17:49:42 +0200

dfoy gravatar image

The single prime (', U+0027) also the mark for foot, as in 3') is the glyph that Writer uses for an apostrophe, but it is not an acceptable substitute in typography (’ U+0146). I understand the error ripples down from somebody's original decision decades ago in assigning glyphs to keyboard keys, when nobody was thinking typographically. But it's a problem. Is there a setting anywhere that changes Writer's default? I get tired of constantly having to run search-and-replace just to correct single primes to apostrophes.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by floris v
close date 2016-09-19 23:38:59.618274

1 Answer

Sort by » oldest newest most voted
2

answered 2016-06-03 22:05:48 +0200

ajlittoz gravatar image

updated 2019-03-30 14:47:24 +0200

Open Tools->AutoCorrect Options..., select Localized Options tab. Tick the Replace check box in the Single quotes column and click OK.

This will replace the single quote U+0027 by the correct typographic glyph both when used as an apostrophe or when used as a quotation mark (in this latter case, you will get the opening and closing delimiters).

If this correctly answers your question, do not forget to tick it for community benefit.

edit flag offensive delete link more

Comments

I've found all th menu items, but simply it doesn't work! kutyacsulok@gmail.com

Sebők Gábor gravatar imageSebők Gábor ( 2019-03-29 08:45:03 +0200 )edit

@Sebők Gábor : Be more specific (LO version, OS, locale). If this is not just a complement to the above question, open a new question because this one is closed can no longer be improved.

ajlittoz gravatar imageajlittoz ( 2019-03-29 09:19:36 +0200 )edit

Win10, LO version 6.2.0.3 The solution doesn't work for me. Instead of ' ,I see ecerywhere the double arrow head.

Cheers,and many thanks! Gábor

Sebők Gábor gravatar imageSebők Gábor ( 2019-03-29 15:41:12 +0200 )edit

Best advice: open a new question (not omitting reference to this one) and attach screen shot(s). You didn't mention your language (this was meant with "locale"). Hungarian?

ajlittoz gravatar imageajlittoz ( 2019-03-29 16:05:07 +0200 )edit

Yes, it's Hungarian. link text

Sebők Gábor gravatar imageSebők Gábor ( 2019-03-30 14:13:44 +0200 )edit

Context not self-descriptive: the replacement table says » (RIGNT-POINTING DOUBLE ANGLE QUOTATION MARK U+00BB -- I assume it is readily available on your keyboard) is replaced by ’ (RIGHT SINGLE QUOTATION MARK U+2019). I'm not sure this is the selected char or U+2018 or even U+00B4 ACUTE ACCENT because picture is not detailed enough. Anyway, this is definitely not U+0027 SINGLE QUOTE.

You may eventually have a conflict between the Replace and Localized Options tabs. Eventually, uncheck Replace in Localized Options after correcting the replacement tab.

ajlittoz gravatar imageajlittoz ( 2019-03-30 14:47:08 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-03 17:49:42 +0200

Seen: 2,488 times

Last updated: Mar 30