Ask Your Question
0

Calc won't sort by date properly.

asked 2016-06-05 08:49:55 +0100

dadashton gravatar image

After years of using Calc it now won't sort by date properly. I normally import a bank statement as a CSV, save as an .xsls file and then sort by date. Now it won't do it.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-06-06 09:50:37 +0100

Edgeberg gravatar image

When opening your CSV file, in the Text Import dialog box, ensure you have the option "Detect special numbers" checked and/or set the column type of the date columns to the type of date that is in the CSV, and that you have set the language correctly. It also helps to have your LibreOffice language settings set appropriately (Tools \ Options \ Language Settings \ Languages); if you don't, you may also need to set the date format of the date columns to your date language after the import.

edit flag offensive delete link more

Comments

I don't understand why oit was doing it right before but not now, as I didn't make any changes to LO myself.

dadashton gravatar imagedadashton ( 2016-06-06 12:46:38 +0100 )edit

The "detect special numbers" option did it. Thanks.

dadashton gravatar imagedadashton ( 2016-06-06 12:53:11 +0100 )edit

Thanks for reporting back, dadashton. Please mark my answer as correct, then, thanks.

Edgeberg gravatar imageEdgeberg ( 2016-06-15 02:55:38 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-06-05 08:49:55 +0100

Seen: 3,216 times

Last updated: Jun 06 '16