Ask Your Question
1

Save ODS as XLS destroyed greek characters [closed]

asked 2012-10-27 19:21:54 +0200

kapcom01 gravatar image

updated 2013-02-01 16:46:00 +0200

qubit gravatar image

I wanted to give an ods file to a microsoft office user so i saved the file as xls and now all characters became question marks. Only the numbers are intact. I tried to open the file as text cvs and selected all the available character sets but the question marks don't change...

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-21 03:52:32.775540

Comments

Are you sure he has the font installed?

m.a.riosv gravatar imagem.a.riosv ( 2012-10-28 01:40:37 +0200 )edit

I never gave the file. The problem is in the same computer after the save as..

kapcom01 gravatar imagekapcom01 ( 2012-10-28 15:27:01 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-02-01 18:17:05 +0200

petermau gravatar image

Somewhere along the line you have a miss match between the text you are using and the character supported in the character sets. I don't use MS office but I assume the problem is the same using XLS.

The � character is the Unicode Replacement Character is the general substitute character for any "unknown" character in a document or spreadsheet. If you export the file as CVS you must choose a character set that contains all the text characters you use. Libreoffice uses Unicode (UTF-8) which contains every character used in Europe and the world. If you choose a character set that does not contain all your text characters you have such, as ISO-8859-1 (Western Europe) or US-ASCII all the missing characters will be replaced and end up as �. Likewise if you import the file into office, the correct character set for import must be chosen. Likewise the Fonts must support the characters used. Hope this helps.

edit flag offensive delete link more

Comments

@petermau, It might be a little clearer to say: "If you choose a character set that does not contain all your text characters, such as ISO-8859-1 (Western Europe) or US-ASCII, all the missing characters will be replaced and end up as �."

qubit gravatar imagequbit ( 2013-02-01 21:54:58 +0200 )edit

Yes, would be a little clearer, but less accurate. The � is a Unicode character and only shown if the software supports Unicode. The replacement character in US-ASCII and ISO-8859-1 X'1A' would show up as a blank space and I was trying to avoid that complication. Sorry if my note was confusing.

petermau gravatar imagepetermau ( 2013-02-01 22:28:54 +0200 )edit

Aha! Well, any folks interested in the nuances of your answer may simply let their eyes walk down the page to our comments here and read the further explanation for themselves. So it all works out quite well in the end :-)

qubit gravatar imagequbit ( 2013-02-01 22:37:15 +0200 )edit

@kapcom01 -- did @petermau's answer work for you? Please mark it as correct if it did, otherwise please let us know what's not working for you.

Thanks!

qubit gravatar imagequbit ( 2013-03-10 06:56:24 +0200 )edit

Question Tools

Stats

Asked: 2012-10-27 19:21:54 +0200

Seen: 730 times

Last updated: Feb 01 '13