Ask Your Question
0

"the requested operation requires elevation" ??

asked 2016-07-01 11:55:07 +0200

Rouchent gravatar image

updated 2016-07-02 00:33:49 +0200

Whenever I try to open a document from my hard drive I get an error message "the requested operation requires elevation". I can only load up libre documents that can be opened from the 'recent documents' list. This means that I cannot open and work upon anything other than the last few documents I viewed. Everything has been working OK up until today. I have re installed libre office but this hasn't helped. Any ideas from anyone as to what I must do?

edit retag flag offensive close merge delete

Comments

Is this Windows? What version? And what version of LibreOffice?

Did you at one point use LO with "Run as administrator"?

RonJohn63 gravatar imageRonJohn63 ( 2016-07-02 03:25:48 +0200 )edit

my computer is windows 7 & LibreOffice 5.1. I don't know if LO was ever used.

mauijudy2 gravatar imagemauijudy2 ( 2016-07-02 21:27:33 +0200 )edit

@mauijudy2 are you the same person as @Rouchent as you seem to be answering a question put to @Rouchent? How did you get the documents on your hard drive if you have not used LO?

peterwt gravatar imagepeterwt ( 2016-07-02 23:49:15 +0200 )edit

This is Rouchent. I have no idea who 'mauijudy2 is!! I have been using LO successfully for years and all the documents were originally created using LO. This issue has occurred only in the last few days. I use Windows XP and have Norton antivirus installed, also for years. Any help would be much appreciated as I have many extremely important business documents and spreadsheets I can no longer access as the 'recent' documents' list is quite limited. Thanks in advance of any help.

Rouchent gravatar imageRouchent ( 2016-07-05 12:00:51 +0200 )edit

P.S. I am using LO 5.1 (version info gained from the properties tab)

Rouchent gravatar imageRouchent ( 2016-07-05 12:02:18 +0200 )edit

This is a "me too" comment- my mother has been using libreoffice for years, and now after a recent upgrade she cannot open any of her files, and instead is receiving a "requires elevation" error. This is NOT a windows problem, this is an LO problem.

brandon.kuczenski gravatar imagebrandon.kuczenski ( 2016-08-15 04:43:33 +0200 )edit

I recently installed LO 5.4 on a new Win-10 x64 pro and had the same problem. I went into the program files folder (c:\Program Files\LibreOffice 5\program) and sorted by file type. (My file explorer is set to display file extensions.) I then right-clicked each of the .exe files, clicked properties, selected the compatibility tab, and checked "Run this program as an administrator" (actually, I changed it for ALL users... don't know if it makes any difference). THIS WORKED!

LogicWriter gravatar imageLogicWriter ( 2017-09-27 23:13:44 +0200 )edit

I changed the permissions for all .exe files in the (c:\Program Files\LibreOffice 5\program) sub directory just as LogicWriter described on Sep 27 '17. I also changed the permission for All users.

TY LOgicWriter!

I had this same problem if I tried to open a file using Open Office, but not if using a Microsoft Product. I would not be surprised if this is being done intentionally, trying to make Office look more attractive.

Lukasha gravatar imageLukasha ( 2017-12-21 05:03:16 +0200 )edit

I also had to right click on the .odt files and select "Properties", on the "General" tab, at the "Opens with", click the "Change" button and change to "LibreOffice Writer". I suspect you will need to do this with all non Microsoft file types. You only have to do this once (maybe after an update) So chug on and keep using LibreOffice and shrug off the MS intimidation. IMO!

Lukasha gravatar imageLukasha ( 2017-12-21 05:09:23 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-07-06 11:35:24 +0200

peterwt gravatar image

@Rouchent it appears that @mauijudy2 has the same problem!! There is a similar posting here. The message “the requested operation requires elevation" in this context usually indicates a problem with file ownership – that the Windows user you are using does not own the file or does not have the required permissions on the file.

Have you made any changes to your PC before this problem arose? Adding or modifying programs? Do you have problems with files that use other programs such as opening images?

You will need to be logged in as a user with admin permissions to do the following. Right click on one of the files that you have a problem with and select Properties. Select the Security Tab. This will show the Users/groups who have access to the file. Is the username you are logged in when you get this problem listed? If so click on that username to show the permissions. All the items except Special Permissions should be ticked. If they are see my comment at the end of this posting.

If they are not ticked then I suggest you first make a copy of the file and operate on that copy. With your username highlighted click on Edit and select Full Control. See if you can now open the file.

If your username is not listed report back on what users are listed.

If your username does have Full Control it may be a problem with your LO profile. Rename the profile (located at username/AppData/Roaming/LibreOffice/(version number)/user) to say olduser. This will enable you to get back to that profile. Open LO which will create a new profile and see if you can now open the problem files. You said that you had reinstalled LO – this keeps the user profile so if there is a problem there it would not have changed it.

edit flag offensive delete link more
0

answered 2017-09-27 23:15:40 +0200

I recently installed LO 5.4 on a new Win-10 x64 pro and had the same problem. I went into the program files folder (c:\Program Files\LibreOffice 5\program) and sorted by file type. (My file explorer is set to display file extensions.) I then right-clicked each of the .exe files, clicked properties, selected the compatibility tab, and checked "Run this program as an administrator" (actually, I changed it for ALL users... don't know if it makes any difference). THIS WORKED! I can double-click a Word or Excel document and it opens.

edit flag offensive delete link more
0

answered 2016-07-14 12:05:30 +0200

Rouchent gravatar image

updated 2016-07-14 12:10:30 +0200

Thank you very much for your detailed reply, Peter. I have Bad news and Good news.

Unfortunately, having tried everything you suggested with the admin permissions on the documents themselves, none of it worked.

Fortunately, whilst searching for LO on my PC to try and carry out the profile renaming I discovered a folder called LibreOffice4. I opened this and it is the old version of LO, as you might have guessed, and seemed to still work entirely independently of LO5.1.

Anyway, I decided to have a go at using the 'open with' command on a document, then browsing for the LO4 folder on my PC and using this to open the document and it worked. I also ticked the 'use this every time' box (or whatever it says) and then just double clicked all my other documents to open them and they all opened perfectly. I made some changes, saved them and opened them again and once more they all worked. Finally, I uninstalled LO5.1 from my PC and everything still works.

So, despite your resolution not being the one I used, you did direct me to the place where I found a way round my problem. So thank you again, very much, for your indirect assistance. You have rescued all my business documents and my sanity.

It looks like I will NOT be upgrading my LO in future in the same manner that I will NEVER be upgrading to Windows 10.

I hope this is also of some help to you, 'mauijudy2'.

Another final BIG THANK YOU to you Peter

Rouchent.

edit flag offensive delete link more

Comments

You might also look at using the "Still" version of LO. Ver. 5.0.6 is the latest. More stable than 5.1. But, hold onto 4 in case it doesn't work.

JSpeed gravatar imageJSpeed ( 2016-07-15 01:04:06 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-07-01 11:55:07 +0200

Seen: 1,546 times

Last updated: Sep 27 '17