Ask Your Question
6

How I can delete empty line after table in Writer? [closed]

asked 2012-11-02 14:10:30 +0200

VitaliyAT gravatar image

updated 2013-05-18 15:00:54 +0200

manj_k gravatar image

For example I want use table in headers and footers, but each time I got empty line after table and should make font size to 1pt or smaller for getting something around.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 10:40:05.385084

Comments

I am here to save your day.

Based on this article I have come up with a simpler idea to get rid of the blank page than transforming the table into text and backwards (with this method the second blank page appears again after any simple editing of the table, so it's almost useless).

The link above will give you one useful comment:

You can never "delete" a page. OOo Writer does not allow you to manipulate pages at all. The page is there because there is document content that needs someplace to appear, so another page is needed. If you hide the final, empty paragraph, or make it small enough so that it fits on the same page as your table, the extra page is not necessary and it will not appear.

So, all you need to do is to move your cursor to the beginning of your ...(more)

Peter Savin gravatar imagePeter Savin ( 2014-08-05 18:08:44 +0200 )edit

Isn't this useless empty paragraph (no one created, so hard to remove) a major bug?

Alias duel zone gravatar imageAlias duel zone ( 2014-08-29 12:21:13 +0200 )edit

problem remains with lo 5.0. i don't have a page issue but have to change the unwanted paragraph after my table can only be reduced to 6. my tables are within frames & the alt+enter in the 1st or last cell doesn't always work.

keng gravatar imagekeng ( 2015-08-19 03:32:31 +0200 )edit

8 Answers

Sort by » oldest newest most voted
1

answered 2012-11-02 15:08:48 +0200

Jean-Baptiste FAURE gravatar image

There is an answer in the French FAQ: http://wiki.documentfoundation.org/FR/FAQ/Writer/158

The idea is to convert the table in text with tabulations -> remove the last paragraph -> convert the text in table.

To convert table <-> text: menu Table > Convert.

edit flag offensive delete link more

Comments

1

A smart workaround ...

manj_k gravatar imagemanj_k ( 2012-11-02 20:29:23 +0200 )edit

It's work, but not useful. Dear developers, could you create normal function or just add ability delete empty line?

VitaliyAT gravatar imageVitaliyAT ( 2012-11-22 09:46:20 +0200 )edit

@VitaliyAT: Please contribute to fdo#45784.

manj_k gravatar imagemanj_k ( 2012-11-22 10:11:17 +0200 )edit

I confirm this method does work. It is all I needed. I made a table and it produced an empty page. I put the pointer in the last cell of the table, I chose Tables > Transform (could be different, mine is in Russian) > Table to text and vice versa. I transformed the table into text, then deleted the invisible character (Ctrl + F10). When I made it a table again,. there was only one page, not 2. Use this wisdom.

Peter Savin gravatar imagePeter Savin ( 2014-08-05 17:33:21 +0200 )edit
8

answered 2012-11-02 16:07:09 +0200

cloph gravatar image

put the cursor at the end of the last cell of the table, then press <ctrl>+<shift>+<del>

To insert a paragraph again, put the cursor at the end of the last cell and press <alt>+<enter>

edit flag offensive delete link more

Comments

Ok for <alt>+<enter> but <ctrl>+<shift>+<del> does not work for me.

Jean-Baptiste FAURE gravatar imageJean-Baptiste FAURE ( 2012-11-02 17:05:37 +0200 )edit

"Ctrl+Shift+Del" still works for me with version 3.5.7, but not any longer with version 3.6.3.

manj_k gravatar imagemanj_k ( 2012-11-02 20:22:58 +0200 )edit
manj_k gravatar imagemanj_k ( 2012-11-02 20:25:18 +0200 )edit
1

Don't working in 3.6.3.2 too. Also I see that is not stable functionality. That's bad.

VitaliyAT gravatar imageVitaliyAT ( 2012-11-12 12:54:14 +0200 )edit
1

you have to have the cursor on the end of content in the last cell of the table... not on the extra line as one would think. worked for me.

gcb gravatar imagegcb ( 2013-11-30 23:05:47 +0200 )edit

What is the right shortcut for a Mac with a standard keyboard (i.e. no numeric keypad)?

Alias duel zone gravatar imageAlias duel zone ( 2014-08-28 20:21:07 +0200 )edit

Works perfectly, for me. Ubuntu 14.04.2 LTS, Keyboard QWERTY set as English International with alternate keys. Cursor at the end of content last row.

raphie gravatar imageraphie ( 2015-03-31 06:47:06 +0200 )edit

works for me with LO 5.3.1.2 on Ubuntu 17.04

jdpipe gravatar imagejdpipe ( 2017-08-27 13:01:43 +0200 )edit

Excellent!! ⌘+⇧+Fn+Del on Mac keyboards (LO 5.3.6).

javizzz gravatar imagejavizzz ( 2017-09-12 22:09:03 +0200 )edit
2

answered 2013-04-03 20:29:31 +0200

manj_k gravatar image

updated 2014-08-29 12:42:21 +0200

Bug 45784 - Removing empty lines after a table
has been marked as a duplicate of
Bug 60967 - EDITING: Table shortcut Ctrl+Shift+Del ineffective cannot delete following paragraph of a table.

EDIT 2013-05-18/2014-08-29
fdo#60967
Status: RESOLVED FIXED
target: 4.3.0 · 4.2.5 · 4.1.0 · 4.0.4 · 3.6.7

Comment #33 by Michael Stahl 2014-05-02:

"fixed the empty-paragraph case from comment #26.

for the paragraph at end of document case (comment #24 and #30) i've done a bit of testing and found that there are quite a few things that break if the document does not end with a paragraph:

  • Load Styles crashes
  • Insert->Footnote then Insert->Index (in the table cell) crashes
  • Select All has numerous problems (and probably requires a special handling similar to table-at-start-of-document, cf. bug 37606), Select All then Delete will crash too
  • ODF export works but ODF import adds a trailing paragraph
  • Word is apparently unable to end the document with a table, so there's an interop issue
  • save as DOC, reopen with LO the table is gone

so i am resolving this bug as FIXED, please file a new bug for the case at document end."

edit flag offensive delete link more
0

answered 2013-12-07 20:03:17 +0200

Wolter gravatar image

Here is an unfriendly workaround which may require understanding the simple XML syntax. Open the document with an archive manager and edit the inbound file content.xml. Find the end of your table and delete the subsequent sequence which takes the form <text:p text:style-name="P5"> ... </text:p>.

Be careful for working within the editor with the about of the edit may revert the changes.

edit flag offensive delete link more
0

answered 2013-01-15 10:53:27 +0200

VitaliyAT gravatar image

4.0.0.1 - not resolved, pity

edit flag offensive delete link more
0

answered 2013-02-13 13:19:52 +0200

ROSt52 gravatar image

Workaround I just used: make the font of the last line, which cannot be deleted as small as possible then the error doesn't appear so obviously.

edit flag offensive delete link more
0

answered 2013-05-19 10:19:53 +0200

ROSt52 gravatar image

v4.0.3.3 portable on XP/SP3 not solved

However comment 12 in bug fdo#60967 indicates that in the next build (after 2013-05-17 22:22:22 UTC ) there is a solution implemented.

edit flag offensive delete link more
0

answered 2013-02-13 13:13:58 +0200

ROSt52 gravatar image

I just tried all listed remedies in 3.6.5.2 nothing worked.

Also added a comment to the bug report

edit flag offensive delete link more

Question Tools

4 followers

Stats

Asked: 2012-11-02 14:10:30 +0200

Seen: 20,791 times

Last updated: Aug 29 '14