Ask Your Question
0

Unable to record macro

asked 2016-08-08 01:05:37 +0200

Joe-- gravatar image

I want to create a simple macro to apply a specific character style to selected text. This is my first attempt at macros, so I figured I'd start by recording the action.

I enabled macro recording in Options.

The docs state to click Tools -> Macros -> Record Macro, and a Recording dialog should appear. However, Tools -> Macros -> Record Macros is a parent menu -- the only option under it is "LibreOffice Basic...", which brings up the macro organizer. I can click New from there, but that just brings me into the macro editor.

I'm sure I'm missing something obvious, but how do I record macros?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-08-08 01:14:25 +0200

paul1149 gravatar image

You must have Java installed and registered in order for Recording to work, and apparently, for the command to be present.

edit flag offensive delete link more

Comments

Is there more to registering java than just having "Use a Java runtime environment" checked off (and a JRE selected) in Tools -> Options -> Advanced? That was already set correctly.

Joe-- gravatar imageJoe-- ( 2016-08-08 01:28:15 +0200 )edit

Switched to JRE 1.7 and I'm in business. Thanks!

Joe-- gravatar imageJoe-- ( 2016-08-08 01:38:24 +0200 )edit

Excellent. If the problem is resolved please mark it as answered so others can find the solution. BW.

paul1149 gravatar imagepaul1149 ( 2016-08-08 02:21:05 +0200 )edit

In Tools > Options > Advanced, I have both "Enable macro recording (limited" and "Use a Java runtime environment" selected, with a path /usr/lib/jvm/java-8-openjdk-amd64/jre. However, I also simply get the option to open "LibreOffice Basic" which brings me to the macro organizer--from there, I can only possibly edit macros, I don't have the option to record a new macro. Am I doing something wrong? TYIA

Ludd1te gravatar imageLudd1te ( 2017-01-21 22:09:16 +0200 )edit

JRE is definitely not required to be enabled to macro recording to work. I explicitly disabled it in advanced settings of LO 5.3.0.3 x64 on Win10 (I have only 1.8.0.121 installed), reloaded LO, and successfully recorded a sample macro.

Mike Kaganski gravatar imageMike Kaganski ( 2017-02-24 06:25:21 +0200 )edit
0

answered 2016-08-08 01:34:04 +0200

m.a.riosv gravatar image

Please test marking:

Menu/Tools/Options/LibreOffice/Advanced - Enable experimental features.

edit flag offensive delete link more

Comments

I had done that, too. I had to switch to JRE 1.7 to get it to work.

Joe-- gravatar imageJoe-- ( 2016-08-08 02:57:56 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-08 01:05:37 +0200

Seen: 551 times

Last updated: Aug 08 '16