Libre Office Fresh too slow to use

asked 2016-08-30 03:59:38 +0200

Mountain gravatar image

I'm running Arch with KDE (Plasma 5) and Libre Office Fresh. Of course Arch has very recent versions of all packages. I'm showing the following version information:

Version: 5.2.0.4 Build ID: 5.2.0-4 CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; Locale: en-US (en_US.UTF-8)

Calc is so slow that it is not even useable. I want to know if anyone else is seeing severe performance problems with Calc on KDE. I'm seeing it on two different Arch installations, both of which are running on very fast modern workstation hardware (e.g., Core i7 machines with fast SSD, plenty of fast RAM, etc.) Compared to a Kubuntu 16.04 installation running standard Libre Office, the Arch machines are literally 1000 times slower.

Should I uninstall Fresh and try Libre Office Still? Or should I go through some troubleshooting steps with Fresh? All options (settings) are default at this point.

I just noticed that under Java Options I have "use a java runtime environment" checked, but my system does not have a JRE installed. What is the best fix? Uncheck that or install Java (otherwise not needed)? I

Is it possible that the default settings could be resulting in such horrible performance? Or do I need to go to LO Still? Thanks for any suggestions.

edit retag flag offensive close merge delete

Comments

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2016-08-30 22:59:11 +0200 )edit

It appears to be a theme problem. Please see a work-around in this thread: KDE + Libre Office Fresh = horrendous performance problems / Applications & Desktop Environments / Arch Linux Forums https://bbs.archlinux.org/viewtopic.p...

Mountain gravatar imageMountain ( 2016-08-30 23:01:34 +0200 )edit

I would like to add information to my question. Is it possible to edit questions? I don't see an edit button -- only flag, close and delete.

Mountain gravatar imageMountain ( 2016-08-30 23:07:43 +0200 )edit

Just a guess: Nvidia graphics card and proprietary driver? That problem likely will be fixed with release 5.2.1

erAck gravatar imageerAck ( 2016-09-01 22:36:27 +0200 )edit

" Is it possible to edit questions?" my newbie 2 cents. Yes, there's an edit but to the left of the buttons you mentioned. In principle, the edit option might close after a period of time, idk, but at least initially, it's there. Try looking again.

ert gravatar imageert ( 2016-09-11 03:50:11 +0200 )edit