Ask Your Question
0

Error when installing openclipart extension

asked 2016-09-23 11:38:17 +0200

linux_matt gravatar image

updated 2016-09-23 11:39:14 +0200

I am getting this error when trying to install a libreoffice extension Failed to register package for vnd.sun.star.expand:$UNO_USER_PACKAGES_CACHE/uno_packages/lu8500ev8wa8.tmp_/openclipart.oxt/python Can anyone identify what the issue might be here? Many thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-06 20:53:46 +0200

burtbick2 gravatar image

I had the same problem. They used to use python-uno which is no longer present, at least under Linux Mint. python-uno has been replaced with libreoffice-script-provider-python.

So if you install libreoffice-script-provider-python and then re-install the extension it should work for you.

There are a couple of things that I see. On LibreOffice Writer in 5.0 the openclipart.org link is under the Insert Media menu item and not under the Insert Image menu.

Also I have not been able to get the openclipart.org option to show up in LIbreOffice Draw, but it does show up in Write.

And I have not been able to get the the save to Gallery option to work, but it does insert the selected clipart into the Writer doc just fine.

Hope this helps if you haven't already resolved the issue.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-23 11:38:17 +0200

Seen: 838 times

Last updated: Dec 06 '16