Ask Your Question
0

how to prevent html p tags paragraphs source from being forced to ~72 characters per line

asked 2016-09-30 16:24:32 +0100

mjassen gravatar image

updated 2016-09-30 16:26:21 +0100

Hi!

Thanks for reading. I've used LibreOffice for various things over the years. Some things I know how to do but I don't by any means know near the full functionality.

This particular behavior has been driving me crazy -- who knows about how to work through (or around) this?

In LibreOffice Writer/Web v.3.5.7.2, when I save my html document, in the resulting html source code why does it force the html paragraphs (<p>-wrapped elements) to have been forced to about ~70 characters wide, and how can I change/prevent this?

(Seems to be forcing a fixed characters per line, as if it were forcing old-style text/plain mime type or something? assuming 72 CPL but don't know)

Anyway, my goal is to have a resulting html source that when viewed in a plain text editor, and when the html page is viewed on iOS safari for that matter, doesn't have any line breaks, so that it is a single line of text per html paragraph. When inputting the text into the LibreOffice Writer/Web interface, I usually paste it as a single line of text without line breaks, and that is how I want it to be saved -- LibreOffice writer seems to be what is adding the line breaks.

What I've tried so far is to look through the edit menu choices and poke around to see if some settings look like they control "characters per line" or "line width", but didn't see any likely settings. I googled and bing-searched some, and that led me to look more in-depth at the tools > options configuration, especially the "LibreOffice Writer > Compatibility > Compatibility options" checkboxes. They look promising but these options don't exist (or are greyed out) for the Writer/Web program.

Guidance appreciated to point me in the right direction!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-10-07 17:06:09 +0100

mjassen gravatar image

My answer is that I'm stopping using the P tag. I know this is a workaround as opposed to finding a way for LibreOffice to do it like I want it.

Now instead of using P tags throughout my blog post, I'm instead using html pre tag encompassing the entire post, and using css to style the pre tag as: "white-space: pre-wrap;" so that the lines wrap when viewed in the browser.

Less work formatting, code looks cleaner, and it works for me to make my blog look readable and a bit more modern.

Considering this symptom solved.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-30 16:24:32 +0100

Seen: 130 times

Last updated: Oct 07 '16