Ask Your Question
0

Menu appearance is hard on the eyes [closed]

asked 2016-10-07 19:33:50 +0100

vico gravatar image

updated 2020-07-19 15:25:19 +0100

Alex Kemp gravatar image

I have been running LO5 on Windows and the menu rendering is nice and clear with obvious separation between menu and sub menu.

I loaded the latest stable LO5 on ArchLinux Virtual Machine and I noticed how bland the menus look. Just plain write rectangles. If I navigate through multiple sub menus and they happen to fall back in the opposite direction due to being at the edge of the screen, it is difficult to tell which is the top sub menu or the parent menu behind it.

Is there a way to make LO5's menus rendered differently? I am using XFCE for the desktop environment atm but it was doing the same thing with LXQT so I don't think the DE is it.

Here is what I am talking about...

dropbox pic

Ideas?

(edit: activated picture)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-07-19 15:26:38.124531

Comments

Sorry, I misunderstood your question, I thought you meant the bland icons in the menus. At a second look I realise you meant the lack of border on the menus, white box on top of white box with no edge visible. Its probably using theme from desktop but I'm not sure. Deleting my answer as its more likely someone else will look at your question.

mark_t gravatar imagemark_t ( 2016-10-07 23:06:56 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-10-08 09:41:55 +0100

vico gravatar image

It appears Libreoffice has been built with support for multiple UI toolkits.

According to

https://wiki.archlinux.org/index.php/...

As of LibreOffice v3.5.x toolkit libraries are checked in the following order: gtk3 > gtk > kde4 > generic

and

To force the use of a certain VCL UI interface, use one of the SAL_USE_VCLPLUGIN=gen, SAL_USE_VCLPLUGIN=kde4, SAL_USE_VCLPLUGIN=gtk or SAL_USE_VCLPLUGIN=gtk3 environment variables. These variables can be uncommented in /etc/profile.d/libreoffice-fresh.sh or /etc/profile.d/libreoffice-still.sh.

On my install the file /etc/profile.d/libreoffice-still.sh had this

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=kde4
#export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3 # currently broken and not available

So I used gtk since all the others did not make a difference and now the menus are drawn clearer, though still nothing to brag about.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-07 19:33:50 +0100

Seen: 325 times

Last updated: Jul 19