Ask Your Question
2

How to Paste Special without 8 clicks the 1st time [closed]

asked 2012-11-16 22:24:14 +0200

LazyKsaw gravatar image

updated 2013-10-21 22:10:24 +0200

manj_k gravatar image

I hope I'm not missing something obvious here, but this behavior annoys me enough that somebody else just ~Must~ have brought it up before, but I can find no reference to it, so here it goes.

Working within Calc, I frequently use Paste Special, mostly to paste only numbers, and also often only formating. The first time I choose Paste Special, the first thing I have to do is un-click Paste All. (I don't really understand why that is the initial default anyway, since it is not a Paste Special at all, but a regular Paste, but I digress...) After that, the 7 choices are now active, and all are selected except for Numbers, which is typically the one I want, so I have to unclick 6 of them and click Numbers, before I can click Okay. That's 8 clicks, and the way I see it, 7 of them are unnecessary. When the Paste Special dialog is first presented, it ought to default to only one, I prefer Numbers, but Text or what ever would be fine too. If it must be Paste All, then unclicking Paste All ought to deselect all the other choices too, that way you can choose the one you want without having to deselect 6 others too.

Is there a way to change this default? Should I make a feature request? Or just suck it up and live with it? Thanks, Carl

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 12:52:34.912975

Comments

In Windows, I use AutoHotkey to do a plain text paste when I press WinKey + V: https://gist.github.com/823381#file-autohotkey-ahk-L471 but this is only one application of Paste Special.

endolith gravatar imageendolith ( 2012-12-12 16:08:02 +0200 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2012-11-17 01:22:40 +0200

m.a.riosv gravatar image

In 3.6 versions there is an option with right-click Paste only. To past only the format you can use the Paint brush icon.

edit flag offensive delete link more

Comments

@mariosv - late so but thanks for this remark. It is already a first step of enhancement I am using now quite often.

ROSt52 gravatar imageROSt52 ( 2013-06-09 11:34:13 +0200 )edit
0

answered 2012-11-17 04:25:44 +0200

ROSt52 gravatar image

I am very happy to see the topic LazyKsaw introduced here!!!!.

The way paste-special is currently handled (LibO 3.5.7) is very unproductive. Description like in the question by LazyKsaw .

My propsal would be 1 - nothing is selected by default and every user can choose what he/she wants to paste without deselecting what is not needed 2 - add a customized "remember" - click what should be pasted and behind the text another checkmark "remember". The "remember can be kept checked or changed on the fly depending on the work a user is doing. A default setting in the Options is too time consuming to change. Thus LazyKsaw would most often keep "Numbers" remembered; I would most often use the same, but I sometimes would also use Comments or Formula.

This would increase productivity a lot!

LazyKsaw if you could please forward an enhancement request.

edit flag offensive delete link more
0

answered 2012-11-30 07:42:01 +0200

LazyKsaw gravatar image

Thanks for the tip about the Paintbrush, mariosv. I wish there was a way to paste formats to more than one cell at a time with it. Or maybe there is and I just don't know it?

ROSt52, if I had a clue about how to forward an enhancement request, I'd be glad to. I'm feeling like such a n00b here! Can you give me some hints about how to go about the enhancement request? Thanks!

edit flag offensive delete link more

Comments

Report a bug https://bugs.freedesktop.org/enter_bug.cgi?product=LibreOffice with detailed description and screenshots (if available). In "Summary:" write "Enhancement request:" and then your wishes

Timon gravatar imageTimon ( 2012-11-30 08:52:09 +0200 )edit

THANKS, Timon!

LazyKsaw gravatar imageLazyKsaw ( 2012-11-30 09:53:13 +0200 )edit
1

As it turns out, this is a previously reported issue. https://bugs.freedesktop.org/show_bug.cgi?id=43442 I went ahead and added two cents worth, maybe somebody will notice.

LazyKsaw gravatar imageLazyKsaw ( 2012-11-30 10:57:31 +0200 )edit

I added my below sketched idea to the bug report / enhancement request. Lets keep fingers crossed that we see this soon.

ROSt52 gravatar imageROSt52 ( 2012-11-30 15:03:58 +0200 )edit
0

answered 2012-11-30 15:06:15 +0200

cloph gravatar image

Another method is to record a simple macro that contains the paste special code with the desired options and to assign that to a toolbar button. This can even be done with the macro recorder alone

  • enable macro recording in Tools | Options → LibreOffice → General
  • copy a cell, so that paste special will be available
  • Record a macro using Tools | Macros → Record macro
  • <>ctrl>+<shift>+v, select desired options, click OK
  • choose a name for the macro and save.

Then go to Tools | Macros → Organize → LibreOffice Basic, select "assign" button. With that you can assign the macro to a menu entry, a toolbar button or a keyboard shortcut.

edit flag offensive delete link more

Comments

That is a nice workaround for the time being. Thanks!

ROSt52 gravatar imageROSt52 ( 2012-11-30 15:20:05 +0200 )edit
0

answered 2012-11-30 20:50:45 +0200

vbas96 gravatar image

updated 2012-11-30 21:03:02 +0200

Macro idea works, but you have to do a number of "finger exercises" -- clicking or keystrokes -- to activate the macro (see my unanswered question on assigning a macro to a menu: click here).

I believe you are trying to copy formulas which have resulted in numbers. Perhaps... A) The formula may be complicated, or B) You're pasting in another section of the sheet (or in a different workbook) where the formula references won't apply, or C) You simply want "hard" numbers to work with.

I do this all the time. I haven't found a way to change the PasteSpecial defaults in my version of LibreOffice Calc, but there are some "best practices" you can apply which will simplify.

Probably you are too strict in choosing your criteria in the PasteSpecial dialog window. Leaving some of the items checked doesn't interfere with the hard-pasting of numbers. The only changes that really need to be made are 1) uncheck "Paste all" 2) check "Numbers" and 3) uncheck "Formulas." Click "OK" and you're done!

To ease your way further I'll emphasize key-strokes instead of mouse-clicks. This will save you from carpal tunnel agony in your clicking finger. Begin by using Ctrl-Shift-V to open the PasteSpecial dialog. Then press the following sequence of keys.

Space-Down-Down - Space-Down-Down - Space - Enter

Space is of course the Space bar. Down is DownArrow. Enter is itself. If you can do this musically (i.e. a drum pattern) it becomes almost fun. It's in 4/4 time, with two sets of triplets, then a beat, followed by a final downstroke. "Space" is the snare drum, "Down" is a tom-tom. "Enter" is a base drum or cymbal. It sounds like "Rum pah pah, Rum pah pah, Rum..Bam"

Spread the joy!

edit flag offensive delete link more
0

answered 2012-12-11 13:39:10 +0200

marcdunord gravatar image

the salomonic solution is to add to the paste special's first menu a tab labelled "default first-screen" or "defaults" in which one saves which checked fields one wants to show up as... "default"... (and the choices are saved forever unless re-modified)

this will increase productivity a lot since it can be optimized to fit the specifics of the work at stake.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-11-16 22:24:14 +0200

Seen: 4,818 times

Last updated: Dec 11 '12