Ask Your Question
0

calc changing 3007:1000 to 3023:40:00... why?

asked 2016-11-01 23:00:38 +0200

miatawnt2b gravatar image

I have a bunch of fields (all numbers) I need to copy/paste into calc in the format xxxx:yyyy. However, if I paste 3007:1000 into calc, it changes it to 3023:40:00.

Why is this and how can I stop it?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-11-02 00:12:20 +0200

Calc thinks it's a number in the form HH:MM and it's converting it to HH:MM:SS (1000 minutes equals 16 hours 40 minutes). The problem with this is that even if you clear the number format it will be changed to 125.9861111.

I didn't find a "paste as string" or anything similar so your best bet is this:

Prepend a single-quote mark (') to each value before pasting [*] to force Calc to interpret your values as strings.

edit flag offensive delete link more

Comments

The problem is I have hundreds of these values to insert. There has to be a way to turn this off globally no?

miatawnt2b gravatar imagemiatawnt2b ( 2016-11-02 16:32:19 +0200 )edit

I don't think so, but there are ways to work around it: - Save them to a CSV and load them from there so you get the Text Import dialog, where you can deselect "Detect special numbers". - Paste it to a plain-text editor, add an extra row and paste all back. Pasting more than one row also makes LibO show the Text Import dialog.

alvarezp gravatar imagealvarezp ( 2016-11-18 00:35:46 +0200 )edit
0

answered 2016-11-02 00:16:56 +0200

m.a.riosv gravatar image

It is converted to time value.

When there are more than one value to paste you can use Menu/Edit/Paste special [Shift+Ctrl+V], click on the column head and select text as type, but it doesn't work with only one value.

Please report the bug: Create a bug report

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-01 23:00:38 +0200

Seen: 31 times

Last updated: Nov 02 '16