Ask Your Question
0

Image orientation in Libre office base [closed]

asked 2016-11-04 14:18:36 +0200

a_lega gravatar image

updated 2020-09-15 00:49:00 +0200

Alex Kemp gravatar image

When I attempt to enter photographs, that I have previously rotated, in a Libreoffice Base form they always appear in their original orientation. From what I've read base probably ignores the orientation tag in the picture's exif data. Is there any way of sorting this without resorting to the use of an exif editor? I must note that images are linked and the wrongly orientated images appears in the image control. LibreOffice 5.2.1.2 (x64) Windows 10

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-09-15 00:49:26.250542

2 Answers

Sort by » oldest newest most voted
0

answered 2016-11-04 14:52:10 +0200

Ratslinger gravatar image

Check your image links. Whether linking or embedding, I see no problem with orientation:

image description

image description

This is using LO v5.2.0.4 on Xubuntu. The image was rotated using GNOME "Image Viewer".

edit flag offensive delete link more

Comments

Thank you for your answer. There doesn't appear to be anything wrong with my links. Image appears in the image control but in the original orientation. I rotated images by right clicking on them in their windows folder and choosing rotate left (or right). All programs open the images correctly (xnview, paint.net, windows image viewer).

a_lega gravatar imagea_lega ( 2016-11-04 22:30:01 +0200 )edit

Sorry but since I don't use Windows any more, I can't help any further. As you can see Linux doesn't have a problem. Hopefully someone else can help.

Ratslinger gravatar imageRatslinger ( 2016-11-04 22:40:27 +0200 )edit
1

After reading your answer I tried opening the images with gimp which, before opening them, shows me a warning about images having been rotated from their original orientation and giving me a choice of rotating them back or keeping them as they are. I choose rotate, then save replacing the original file and voila everything works great. Problem is probably due to the way windows rotate images.

a_lega gravatar imagea_lega ( 2016-11-04 22:53:40 +0200 )edit

Always glad to hear problem solved. Thought it was something with Windows but no way of checking.

Ratslinger gravatar imageRatslinger ( 2016-11-04 23:32:15 +0200 )edit
1

answered 2016-11-05 07:53:45 +0200

a_lega gravatar image

OK, it's definitely a Windows 10 issue. Sorry for you time everybody! There's a whole 8 page thread here, offering no solution whatsoever. Simple answer to the problem is not to use the Windows explorer rotate function to rotate images that will be used in any other application.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-04 14:18:36 +0200

Seen: 338 times

Last updated: Nov 05 '16