Ask Your Question
0

My keyboard stops responding in Writer, and cursor moves backwards

asked 2016-11-17 15:19:20 +0200

Here's an interesting one for you (I hope). When I'm working on a document in Write, and occasionally in Calc, the keyboard suddenly freezes and the arrow keys start sending the cursor in the wrong direction. The only way to right the problem is to shut down LibreOffice entirely, and start it up again. Once in a while, not even that works, and I have to restart my entire system.

The problem is that I'm a copy-editor, working on a 700-page typescript with a tight deadline. I really can't afford to lose (on average) an hour or more a day simply switching it off and on again. I was hoping that we'd progressed beyond Tech Support 101 by this stage of the project.

I'm running Ubuntu 14.04 on an HP Mini netbook, with all the latest software updates installed and the residue removed by Ubuntu Tweak. Version: 5.2.3.2 Build ID: 1:5.2.3~rc2-0ubuntu1~trusty1 CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; Locale: en-GB (en_GB.UTF-8); Calc: group

If you can offer me any advice, or if anyone has a similar issue, I'd be delighted to hear from you. Thanks!

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2016-11-18 09:57:12 +0200

Librefr gravatar image

Hello ! I have never heard such a problem before so I suppose it's a system problem ! If you want you can boot on a Mint Key (Mate version perhaps for your mini netbook). https://linuxmint.com/ I use Mint and it's very reliable and easily configurable. http://distrowatch.com/table.php?dist... Tell us if you have a problem with Libreoffice under Mint

edit flag offensive delete link more

Comments

I really can't take the risk of losing everything by installing a whole new OS at this stage of the game. Maybe in three weeks' time, when the novel is back with the author, I'll have a look at it. Thanks,

Full Marks Editor gravatar imageFull Marks Editor ( 2016-11-18 16:26:25 +0200 )edit
0

answered 2016-11-18 11:35:23 +0200

Lupp gravatar image

updated 2016-11-18 18:27:42 +0200

1) Did you enable (do you need) 'Complex text layout (CTL)' and/or 'Asian' writing? As there are many languages written from right to left this might be a background condition for your experiences. By default there are also two icons for working under CTL (pens with faint arrows) for setting the direction of writing in the 'Formatting' toolbar.

2) Strange errors (like an inadvertent reversion of that direction) are sometimes caused by user profile corruption. See this wiki page.

3) Fighting problems with a corrupted installation of LibreOffice you may also temporarily(?) use a LibO expanded extracted from a package in the PortableApps format. Such packages are downloadable for many versions from this location. All the PortablApps versions are presently Win32. They (and the PortableApps platform, too) should, however, also work on the WINE layer.

edit flag offensive delete link more

Comments

No, I'm working in the English language, so that can't be anything to do with Option 1. I'll have a look at Option 2. Thanks. I only understood about one word in three of Option 3.

Full Marks Editor gravatar imageFull Marks Editor ( 2016-11-18 16:25:18 +0200 )edit

Ad 1) The CTL option may be chosen idependent of what language you are working in. Do you have the icons I mentioned?
Ad 2) This helped me to get rid of strange problems in a few cases. Be careful, however, not to lose your templates, macros or something. Your preferred settings will need renewal after a user profile reset.
Ad 3) The problem is surely due to my bad English. If you actually want to try a LibO needing no installation, please tell me. I will try again then.

Lupp gravatar imageLupp ( 2016-11-18 18:34:15 +0200 )edit

Thanks for the suggestions again, and sorry it's taken me a while to reply. I've been so busy with the book I haven't had chance to do anything else. Once I've finished with this, I'll have a look at your feedback in more detail - but I can't risk losing my work at this stage. Have a good weekend!

Full Marks Editor gravatar imageFull Marks Editor ( 2016-11-27 17:47:17 +0200 )edit
0

answered 2016-11-30 11:40:50 +0200

After a few days of constant freezing, I decided to follow Lupp's advice and turn back the metaphorical clock. I stripped out the very latest version, and reinstalled the default Ubuntu version from the command line. Since then it's been working fine. Kinda undermines everyone's advice to keep your system and make sure you're running the most up-to-date software, doesn't it? :-)

edit flag offensive delete link more

Comments

it's nice ! thank for the feedback

Librefr gravatar imageLibrefr ( 2016-12-01 10:04:41 +0200 )edit
0

answered 2016-11-18 18:37:22 +0200

petermau gravatar image

If it were me, I would first need to check that there is no touchpad problem, either hardware or software. I would disable the touchpad and plug in a USB connected mouse. I have seen a similar problems caused by both touchpad and mouse. It is a quick test to make.

edit flag offensive delete link more

Comments

I was wondering about the trackpad as well, Peter. I'll try the external mouse option and see what happens. Thanks.

Full Marks Editor gravatar imageFull Marks Editor ( 2016-11-27 17:47:57 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-11-17 15:19:20 +0200

Seen: 362 times

Last updated: Nov 30 '16