Ask Your Question
0

convert to csv with command line and save formula's as result

asked 2016-11-22 15:10:39 +0100

NicoVanLeeuwen gravatar image

Hi,

I'm using the command below to save my excel file to a csv file and it works perfect.

"C:\Program Files (x86)\LibreOffice 5\program\soffice.exe" --nofirststartwizard --convert-to csv:"Text - txt - csv (StarCalc)":"59,34,76,2,,,true,,false" file.xlsx

The last "false" option I have tried in an attempt to convert an excel file containing formulas but this results in "504" messages instead of results. It's for all formulas but I have not yet found a clue on why. Found that the 504 message has something to do with it being of the wrong type (number or text).

Can anybody point me in the right direction ?

Thanks, Nico

edit retag flag offensive close merge delete

Comments

As you assumed, Err:504 is some "illegal parameter" error. And then the crystal ball went foggy.

erAck gravatar imageerAck ( 2016-11-24 20:50:09 +0100 )edit

Ok, then I will minimize the data and try to find the issue with really babysteps and see where it goes "foggy" :-)

NicoVanLeeuwen gravatar imageNicoVanLeeuwen ( 2016-11-26 11:08:42 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-21 12:33:16 +0100

NicoVanLeeuwen gravatar image

After a bit of trial and error I found the issue for my situation...

It turns out that : =VERT.ZOEKEN($A2;LiveData;2;ONWAAR) is not working and gives back a 504 error =VERT.ZOEKEN(A2;LiveData;2;ONWAAR) is working like a charm

Have not found if this is a documented feature but still would like to share my solution for this.

edit flag offensive delete link more

Comments

Both, relative and absolute cell references, generally work, I assume there's something else different in your case.

erAck gravatar imageerAck ( 2017-01-06 18:19:53 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-22 15:10:39 +0100

Seen: 336 times

Last updated: Dec 21 '16