Ask Your Question
0

I Need a LibreOffice that will work on my Ubuntu 16.04

asked 2016-11-25 04:47:35 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I just got a new laptop and installed Ubuntu 16.04 on it as this OS will work with the laptop's touch pad. We use 14.04 here at the office but 14.04 would not work with this laptop's touch pad. However LibreOffice is not working over the network with Ubuntu 16.04. Here is what I have tried: 1. LO 5.2.3.3 - Opens Writer and Calc over the network but I cannot access Base databases over the network (I get a macro error code when I try to open it saying: Error 1: An exception occurred Type: com.sun.star.ucb.InteractiveAugmentedIOException Message: Operation not supported by backend. (line : 17) But it opens Base files copied to the desktop just fine. 2. Tried LO 5.1x the default version and none of the LO documents (Base, Writer or Calc) would open over the network. 3. I tried to revert back to 4.2.8.2 which works fantastic with Ubuntu 14.04, but it would not open any files over the network in Ubuntu 16.04. 4. I tried LO 4.1.3.2, which worked fine over the network using Ubuntu 14.04 after a fix in the terminal where I commented out a line in the apport file I believe. I tried this fix and it does not work in Ubuntu 16.04.

I am at my wit's end, my annoying boss insists on being able to open Base over the network on this laptop, please if anyone could help me I would be eternally grateful :)

edit retag flag offensive close merge delete

Comments

I'm just curious. When you say "cannot access Base databases over the network", which type of databases do you mean, e.g. MySQL, MariaDB, or other? And if so are you connecting with JDBC or ODBC? Or am I way off track?

EasyTrieve gravatar imageEasyTrieve ( 2016-11-26 06:25:20 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-11-25 20:13:51 +0200

On Ubuntu, don't install LibreOffice from .deb files.

Just open a terminal and type:

sudo apt install libreoffice

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-25 04:47:35 +0200

Seen: 925 times

Last updated: Nov 25 '16