Ask Your Question
1

Can not install 5.2.3.3

asked 2016-11-29 15:49:43 +0200

pjc123 gravatar image

updated 2016-11-29 16:36:39 +0200

During the install of 5.2.3.3 it was looking for the old 5.2.2 msi file so it could uninstall the old version (Once an update is installed I never keep this file). As a result, the install rolled back. This never happened before, and as I said I never keep that file. I installed the Win 10 anniversary update just before this happened, so it is possibly related? I tried cleaning everything with CCleaner, so now I have no working version. So, really in a bind now as I need libreoffice to do some work. If reinstalling 5.2.2 works, where do I find that file; I can only find 5.2.2.2? Can I manually clean everything out? I will get the exact error message when I get a chance, but the above is the gist of it.

edit retag flag offensive close merge delete

Comments

5.2.2.2 is the 5.2.2 release (RC2 became the release).

erAck gravatar imageerAck ( 2016-11-29 16:41:07 +0200 )edit

@erAck: that's exactly what I hate about LO: confusion-inducing versioning.

rautamiekka gravatar imagerautamiekka ( 2016-11-29 19:42:16 +0200 )edit

You surely have a better approach to suggest then which would everyone confuse less.

erAck gravatar imageerAck ( 2016-11-30 14:29:23 +0200 )edit

5.2.2.2 is the full version. Use that, not 5.2.2, which also saves using different code to make names.

rautamiekka gravatar imagerautamiekka ( 2016-11-30 16:50:13 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-11-29 23:44:17 +0200

pjc123 gravatar image

RESOLVED. So after searching the Internet all afternoon I found the proper file "LibreOffice_5.2.2_Win_x86.msi" at some university somewhere. But as it turns out it looks as if it is just a 5.2.2.2 installer (As noted on the header) that was renamed. So all I probably needed to do was to:

Download and rename this:

LibreOffice_5.2.2.2_Win_x86.msi

to this:

LibreOffice_5.2.2_Win_x86.msi

for it to work. Don't ask me why; a Microsoft thing, a LibreOffice thing? I was then able to do a repair of the install, reinstall the old help file, and then install 5.2.3.3 and the new help file without incident. What a two day nightmare.

edit flag offensive delete link more

Comments

Didn't know Windows is that picky about the file name of the installer.. thanks.

erAck gravatar imageerAck ( 2016-11-30 14:28:21 +0200 )edit
0

answered 2016-11-29 16:32:23 +0200

erAck gravatar image

As you mentioned in question 82749 you used CCleaner that likely removed the msi file. Try to repair your installation using the 5.2.2 msi file (or x86_64 if you use the 64-bit version).

edit flag offensive delete link more

Comments

Thanks for the download. Will report back if it works.

pjc123 gravatar imagepjc123 ( 2016-11-29 16:38:47 +0200 )edit

No Go. Same exact problem. According to the pop-up message it specifically needs "LibreOffice_5.2.2_Win_x86.msi" NOT version 5.2.2.2 (with the extra 2) in order to continue with the install. I searched for that version and could not find it anywhere. I suspect that would fix the problem.

Also, CCLeaner is completely unrelated to this specific problem; that was after.. I always manually remove the msi before the next update to save space and that has always worked in the last couple of years

pjc123 gravatar imagepjc123 ( 2016-11-29 18:08:37 +0200 )edit

Going to try version 5.2.2.1 next as soon as it downloads. Maybe it is the same as 5.2.2 since there is no 5.2.2.

pjc123 gravatar imagepjc123 ( 2016-11-29 18:51:53 +0200 )edit

Also, when I cancel out of the install (Because I have no choice) here is the error message:

"Error 1714: The older version of LiberOffice 5.2.2.2 cannot be removed. Contact your technical support group."

OK then, Is there at technical support group?

Man, I would really, really hate to roll back to my image backup and lose a brutal days time with the Win 10 Anniversary install on this slow machine, just to get to a working LibreOffice. That would suck big time!

pjc123 gravatar imagepjc123 ( 2016-11-29 18:52:31 +0200 )edit

Version 5.2.2.1 also requires version 5.2.2 to continue. Out of ideas at this point, unless someone can find version 5.2.2 somewhere.

pjc123 gravatar imagepjc123 ( 2016-11-29 19:15:25 +0200 )edit

Well, just read what was written above in the other answer: get LibreOffice_5.2.2.2_Win_x86.msi and rename it to LibreOffice_5.2.2_Win_x86.msi

erAck gravatar imageerAck ( 2016-12-05 19:47:06 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-29 15:49:43 +0200

Seen: 226 times

Last updated: Nov 29 '16