Ask Your Question
0

LibreOffice 5.2.3.3 Install Fails [closed]

asked 2016-12-03 16:50:51 +0200

James G. gravatar image

updated 2020-09-16 11:55:59 +0200

Alex Kemp gravatar image

While I have found a resolution, I'm curious about the installer for 5.2.3.3 (x86) and its failure to install on Windows 10.

I conducted an upgraded for 5.2.2.2 (x86) the other day and the install failed. The error received was "Error 1335. The cabinet file 'libreoffice1.cab' required for installation is corrupt and cannot be used."

I tried a number of approaches posted, including installing LibreOffice 5.2.3.3 using admin permissions granted through the registry and command line using msiexec /a. All resulted in the same error.

However, as I stated above, I did find a fix. But it required either installing LibreOffice 5.1.6 (x86) [Still] or LibreOffice 5.2.3.3 (x64) [Fresh]. The x64 version must be downloaded by scrolling down to the "Available Versions" section on the Fresh version download page, the default download is to x86. I did not need to use admin switches or run as commands when installing these versions.

So this raises a few questions:

  1. Is the 5.2.3.3 (x86) installer for Windows corrupt?
  2. Why would it make a difference in the level of success installing these different versions?
  3. How do I find an archived version of an installer for a prior version of LibreOffice? I couldn't find version 5.2.2.2 after a long search.

Thanks!

(Edited for more clarity. Cf. Comment by @rautamiekka)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-09-16 11:59:12.882189

Comments

5.2.3.3 or 2.2.3.3 ? You use both interchangeably, but I know LibreOffice existed as 3.0 the first time, meaning there's no LO 2.x. Anyway, try to fix your typos.

rautamiekka gravatar imagerautamiekka ( 2016-12-03 20:27:13 +0200 )edit

As far as I can remember the very first version released by TheDocumentFoundation got named LibO V3.3.

Lupp gravatar imageLupp ( 2016-12-04 15:54:16 +0200 )edit

@Lupp: Likely it was. I didn't check for the exact version, but I know there was no such thing as LO 2.x.x, while 3.x.x was.

rautamiekka gravatar imagerautamiekka ( 2016-12-04 16:09:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-03 18:18:18 +0200

m.a.riosv gravatar image

updated 2016-12-04 14:53:52 +0200

https://ask.libreoffice.org/en/questi...

edited: 20161204

I don't remember an issue like this for me, and I install several LO for test at week, and I have Win10 since it was released.

I remember people having issues downloading with IE, I always use FireFox with DownThemAll extension.

You can find all versions for all OS on: https://downloadarchive.documentfound...

edit flag offensive delete link more

Comments

@m.a.riosv, thanks for the response. However it looks to be a chronic issue for LibreOffice. The links within the links, point out this issue has been going on for years (start of Libre project?). Some of the links state there was file corruptions with response with fixes from the community fixing the issue, others point to Windows permissions, for rollbacks there are links pointing external download sites. Sadly this didn't address the questions I posted above. Especially questions 2 and 3.

James G. gravatar imageJames G. ( 2016-12-03 19:20:23 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2016-12-03 16:50:51 +0200

Seen: 630 times

Last updated: Dec 04 '16