Ask Your Question

When copying from control table to cal file its copy all columns of table but copy only columns as defined in control table.

asked 2017-01-16 11:37:54 +0200

koolninja gravatar image

updated 2017-01-16 11:39:52 +0200

When copying from control table to cal file its copy all columns of table but i want only columns to copy as defined in control table.

Example... Table 1 have A B C D E F columns defined But in Control Table only B D E F defined to view, so i want to copy only these columns which i view

may can anyone give idea to override this problem

Thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2017-01-16 16:59:45 +0200

Ratslinger gravatar image

updated 2017-01-16 17:08:11 +0200

It is a bit unclear what a "cal file" is, but an educated guess is a spreadsheet. If so, just create a Query in Base such as:

SELECT B, C, D, E, F FROM "Table 1"

Then use this query as the data source in the spreadsheet.

edit flag offensive delete link more


It's spreadsheet . I had created multiple search in base form using main form and sub form with search query. Displaying search results in control table as I don't know direct print method, so I use copy method and paste into spreadsheet. It's copy all columns of tablet to spreadsheet but I need selected columns to be copied as display in control table

koolninja gravatar imagekoolninja ( 2017-01-16 19:07:46 +0200 )edit

Create another query based on the query you have for your search but only select the columns you want displayed. In the spreadsheet (database must be registered), from menu View->Data Sources will display the tables/queries for registered databases. Select the newly created query and drag down to spreadsheet. Use, from menu, Data->Refresh Range if your search has changed.

Ratslinger gravatar imageRatslinger ( 2017-01-16 20:25:16 +0200 )edit

I will give try to it. Thanks for advice

koolninja gravatar imagekoolninja ( 2017-01-17 15:23:07 +0200 )edit

It's working very well. Thanks for proper solution

koolninja gravatar imagekoolninja ( 2017-01-18 15:59:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2017-01-16 11:37:54 +0200

Seen: 43 times

Last updated: Jan 16 '17