Ask Your Question
0

Alt Gr (right) + n opens "tools" instead of writing ń letter

asked 2017-01-28 13:26:09 +0200

NoiRioN gravatar image

Hi there, I'm trying hard to use LibreOffice instead of MS Office. Unfortunately, trying to write ń letter (Polish diacritics = ctrl + alt + n, or alt gr + n) does open the "tools" menu (Narzędzia in Polish).

There is no shortcut configurable anywhere to get rid of it. How then make writing ń with Alt Gr + n possible again? Using tylda (~) to write it is not a very ergonomic option, being the only one possible right now...

PS Checked on two Windows 10 computers with different components and different OS editions. Both with no luck.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2017-01-29 00:23:37 +0200

LibreTraining gravatar image

Check the language setting on your keyboard. And your Location setting.

These both affect how Windows maps the keyboard.

edit flag offensive delete link more

Comments

Checked before writing anything. All settings are proper on both computers. Every other piece of software works fine; only LibreOffice doesn't.

NoiRioN gravatar imageNoiRioN ( 2017-01-29 15:42:11 +0200 )edit

It appears the right Alt key has multiple issues.

I have all US settings on Win7 and the right Alt key does not work as expected (same as left).

Did the same as you, checked all the settings.

Appears to be a bug, or multiple bugs.

LibreTraining gravatar imageLibreTraining ( 2017-01-29 18:38:47 +0200 )edit

Good to know we're not the only ones here with the problem on multiple devices...

Definitely a bug.

NoiRioN gravatar imageNoiRioN ( 2017-02-10 18:55:12 +0200 )edit
0

answered 2017-01-29 00:59:16 +0200

robleyd gravatar image

A similar question was asked at https://ask.libreoffice.org/en/questi...

edit flag offensive delete link more

Comments

Unfortunately not similar. As I wrote in the longer comment, the problem user has there is with using left and right alt both as the same button, while right alt is Alt Gr and it stopped working as the left one, which "works fine". So, the problem is completely opposite to my. I don't want both alts to work the same. I want Alt Gr to work as Alt Gr properly, while it doesn't for Alt Gr + N combination.

NoiRioN gravatar imageNoiRioN ( 2017-01-29 15:41:36 +0200 )edit
0

answered 2017-01-29 11:50:06 +0200

peterwt gravatar image

See here

edit flag offensive delete link more

Comments

I wonder, how is this one to be in any way helpful? It may be surprising to you, but I do really know what is Alt Gr for, how does it work, etc. And the problem is, that the Alt Gr + N does not work properly ONLY in Libre Office...

NoiRioN gravatar imageNoiRioN ( 2017-01-29 15:39:50 +0200 )edit

As this only applies to the one key for ń and only in LO then submit a bug report at bugzilla

peterwt gravatar imagepeterwt ( 2017-01-29 16:36:40 +0200 )edit

Thank you, I'll do so.

NoiRioN gravatar imageNoiRioN ( 2017-02-10 18:53:46 +0200 )edit
0

answered 2017-01-29 15:35:46 +0200

NoiRioN gravatar image

I wouldn't ask, if the question was answered there. I also wouldn't ask here, if it was Windows key mapping problem. But let's be 100% accurate and repeat the information written above in even more obvious way.

My RIGHT ALT == ALT GR does work PERFECTLY in any application that ain't LibreOffice. I can write ń here, in Chrome. I can do it in Run command, and in Windows Start Menu. I can write it in notepad. And everywhere else, but not in Libre Office. That does cut off Windows local settings, doesn't it? I have Polish -> Polish (programmist) keyboard language setup, Polish Windows setup, and Polish locale setup. You can't be more Polish than that...

Ok, so maybe it's Libre Office settings? NOPE, it ain't. I did check out LibreOffice installed from English installer, and Polish installer, both with all combinations of languages. And always for Tools (Narzędzia) menu item, right alt does work as left alt, which is wrong. Oh, sorry, for English interface setup and Polish locale setup IN Libre Office, first right-alt + n does nothing, and second does write "n".

So, there you go. I don't have a foggiest why you linked up the Wikipedia for Alt Gr - you know, I pretty use it for every day basis here in Poland, and it ain't any surprise to me that right alt and left alt are different keys indeed, so... that seems to be a bit mean. The "similar question" ain't very similar, as there guy does have completely opposite problem: he doesn't want to use Alt Gr as he should, he does want it to work as left Alt - for toolbar highlight. Meanwhile, I wan't the opposite: I wan't to use right alt as Alt Gr for making diacritics letters. And I can do it for every letter I need but n: ę ó ą ś ł ż ź ć. And with ń there is a problem, where Libre Office treats that right alt, Alt Gr as left alt, and turns on the Tool (Narzędzia) menu.

So, after this long and redundant description, can you please help me with my issue, and tell me where is the "magical switch" that turns off the right alt + n interpretation as left alt + n? No, it ain't in keyboard settings in customization, I checked it out. So where may it be? Is there some configuration file with error in it? Or is it a bug that noone understands and noone set it up as a bug to be solved?

Please help. Thank you.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-01-28 13:26:09 +0200

Seen: 1,096 times

Last updated: Jan 29 '17